# CVE-2026-59885: pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service

> Attackers can cause denial of service in applications using pyasn1 by sending crafted ASN.1 data with many OID arcs, consuming excessive CPU.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** AZL-92430, BELL-CVE-2026-59885, CLEANSTART-2026-EM41513, DEBIAN-CVE-2026-59885, ECHO-4cac-d3b9-56bc, GHSA-8ppf-4f7h-5ppj, MINI-2p6r-q22h-8vmh, MINI-3247-623w-2463, MINI-38x7-w5pg-5vq8, MINI-4397-xq49-g7p4, MINI-49v9-xwm7-57jj, MINI-4c25-4x6h-qcx4, MINI-5px6-j45f-5xmw, MINI-67v6-5hpg-cgr5, MINI-6wch-w4gg-rwvp, MINI-7mpp-6x6c-33m6, MINI-7r49-crh5-49h3, MINI-8873-gjgf-c65q, MINI-8qj9-w3pm-9666, MINI-94mh-64vv-fqv9, MINI-9mgw-mm26-jx5h, MINI-9p8f-rw58-8rxj, MINI-f7w7-736x-47qr, MINI-h7x7-62mm-ww6q, MINI-hvfg-hh7c-66cf, MINI-mhq9-33r3-c778, MINI-pjc4-pxrq-whg3, MINI-pmxx-qc2p-248h, MINI-rxc3-c9r2-8vpq, MINI-v6cm-92pw-58w9, MINI-wj94-wrgr-82cp, MINI-wpq8-rmrf-m68c, MINI-wqg7-5v7q-9h29, MINI-xjxh-cgqj-r4m6, PYSEC-2026-3456, ROOT-APP-PYPI-CVE-2026-59885, UBUNTU-CVE-2026-59885

## What is CVE-2026-59885?

CVE-2026-59885 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER, CER, and DER decoders process OBJECT IDENTIFIER and RELATIVE-OID values in quadratic time relative to the number of arcs, so a small crafted payload containing an OID with many arcs consumes excessive CPU per decode() call and can deny service to applications that decode untrusted ASN.1 data. The corresponding encoders have the same quadratic behavior when an application re-encodes previously decoded attacker-supplied values. This issue is fixed in version 0.6.4.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59885?

3 open source packages ship an affected version, including pyasn1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyasn1` | PyPI | All versions | 0.6.4 |
| `pyasn1` | PyPI | All versions | 0.6.4 |
| `pyasn1` | PyPI | All versions | 0.6.4 |

Products: Pyasn1 Pyasn1.

## How do I fix CVE-2026-59885?

Upgrade pyasn1 to 0.6.4 or later.

## Is CVE-2026-59885 being exploited?

There is no known exploitation of CVE-2026-59885 in the wild and no public exploit code.

## Other vulnerabilities in pyasn1

- [CVE-2026-59884](https://insights.sbomify.com/CVE-2026-59884/): pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs (high 7.5)
- [CVE-2026-59886](https://insights.sbomify.com/CVE-2026-59886/): pyasn1: Uncontrolled resource consumption when converting decoded REAL values (high 7.5)
- [CVE-2026-30922](https://insights.sbomify.com/CVE-2026-30922/): pyasn1 Vulnerable to Denial of Service via Unbounded Recursion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59885 and fix it if it is affected.

What it is: CVE-2026-59885 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59885 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59885/ (Markdown: https://insights.sbomify.com/CVE-2026-59885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59885
- OSV: https://osv.dev/vulnerability/CVE-2026-59885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59885/
Summaries are generated and may contain mistakes; the official description above is the record.
