# CVE-2026-59890: setuptools: MANIFEST.in exclusion bypass in sdist via Unicode normalization collision (NFC/NFD) on macOS APFS/HFS+

> Attackers can bypass file exclusion rules in source distributions on macOS by exploiting Unicode normalization collisions, potentially leaking sensitive files.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** AZL-110366, AZL-92229, BELL-CVE-2026-59890, BIT-setuptools-2026-59890, CLEANSTART-2026-BQ91197, CLEANSTART-2026-DF15626, CLEANSTART-2026-HV14791, CLEANSTART-2026-LY41843, CLEANSTART-2026-PZ20042, CLEANSTART-2026-XW51025, CLSA-2026-1786468462, CLSA-2026-1787028610, CLSA-2026-1787559705, CLSA-2026-1790749457, CLSA-2026-1791366380, CLSA-2026-1791366704, ECHO-732c-d358-5fef, GHSA-h35f-9h28-mq5c, MINI-2gh9-q385-hr2m, MINI-2qh3-v3f6-3pvx, MINI-5gr6-r242-f66p, MINI-5jg2-9vm3-7cc5, MINI-5r4w-39wc-5xf5, MINI-835q-m3f4-f73q, MINI-f632-6jhm-593p, MINI-mh43-jg27-c8gh, MINI-wm2q-crjp-49fh, MINI-xmhx-997j-pggv, OESA-2026-3191, PYSEC-2026-3447, RHSA-2026:37530, UBUNTU-CVE-2026-59890

## What is CVE-2026-59890?

CVE-2026-59890 is a medium-severity vulnerability in pypa setuptools, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

setuptools is a package that allows users to download, build, install, upgrade, and uninstall Python packages. Prior to 83.0.0, FileList applied MANIFEST.in exclude, global-exclude, recursive-exclude, and prune directives by matching compiled glob patterns against on-disk file names without Unicode normalization, so on macOS APFS or HFS+ an NFD file name could bypass an NFC exclusion rule and be packed into a source distribution. This issue is fixed in version 83.0.0.

Weakness: CWE-697 (Incorrect Comparison), CWE-176 (Improper Handling of Unicode Encoding)

## Which versions are affected by CVE-2026-59890?

4 open source packages ship an affected version, including setuptools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `setuptools` | Bitnami | All versions | 83.0.0 |
| `setuptools` | PyPI | All versions | 83.0.0 |
| `setuptools` | PyPI | All versions | 83.0.0 |
| `setuptools` | PyPI | All versions | 83.0.0 |
| `python-setuptools` | Red Hat:hummingbird:1 | All versions | 0:83.0.0-4.hum1 |
| `python-setuptools-wheel` | Red Hat:hummingbird:1 | All versions | 0:83.0.0-4.hum1 |
| `python3-setuptools` | Red Hat:hummingbird:1 | All versions | 0:83.0.0-4.hum1 |

Products: Python Setuptools.

## How do I fix CVE-2026-59890?

Upgrade setuptools to 83.0.0 or later.

## Is CVE-2026-59890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59890 exists.

## Other vulnerabilities in pypa setuptools

- [CVE-2013-1633](https://insights.sbomify.com/CVE-2013-1633/): Setuptools vulnerable to Man-in-the-middle attacks (medium 6.8)
- [CVE-2022-40897](https://insights.sbomify.com/CVE-2022-40897/): pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59890 and fix it if it is affected.

What it is: CVE-2026-59890 is a medium-severity vulnerability in pypa setuptools, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59890 exists.

Affected packages and fixed versions:
- setuptools (Bitnami): affected all versions; fixed in 83.0.0
- setuptools (PyPI): affected all versions; fixed in 83.0.0
- setuptools (PyPI): affected all versions; fixed in 83.0.0
- setuptools (PyPI): affected all versions; fixed in 83.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59890/ (Markdown: https://insights.sbomify.com/CVE-2026-59890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59890
- OSV: https://osv.dev/vulnerability/CVE-2026-59890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59890/
Summaries are generated and may contain mistakes; the official description above is the record.
