# CVE-2026-59892: OpenTelemetry JavaScript: Denial of service in `JaegerPropagator` via unhandled exception on a malformed header

> An unauthenticated remote attacker can crash a Node.js process by sending malformed HTTP headers to applications using the JaegerPropagator.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLEANSTART-2026-SG26208, CLSA-2026-1791460637, CLSA-2026-1793272717, CLSA-2026-1793272846, CLSA-2026-1793275058, ECHO-52e8-4aea-0197, GHSA-45rx-2jwx-cxfr, MINI-6v5g-j9wr-qvr9, MINI-6xrv-mrvp-7h26, MINI-7rx8-mvcg-2fp9, MINI-9r65-84fj-rx4p, MINI-cp29-xxcv-2cxr, MINI-ghfg-m28q-3mp6, MINI-jfq2-frc5-xxmr, MINI-m7vh-gqw2-c3c5, MINI-mm5f-r3gm-xr2x, MINI-qjv9-r6c3-hhvh, MINI-r325-7m6p-pgwp, MINI-vwfc-75mh-wxch, MINI-wjxj-3vff-qxfq, MINI-x79m-fmmf-3w93, MINI-xhxc-crcg-6f64, ROOT-APP-NPM-CVE-2026-59892

## What is CVE-2026-59892?

CVE-2026-59892 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-js, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenTelemetry JavaScript is the OpenTelemetry JavaScript client. Prior to 2.9.0, @opentelemetry/propagator-jaeger decodes incoming uber-trace-id and uberctx-* HTTP header values with decodeURIComponent() without handling decode errors, allowing an unauthenticated remote attacker to send a malformed percent-encoded value that throws an uncaught URIError and terminates a Node.js process using JaegerPropagator as the active propagator. This issue is fixed in version 2.9.0.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-59892?

2 open source packages ship an affected version, including @opentelemetry/propagator-jaeger.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@opentelemetry/propagator-jaeger` | npm | All versions | 2.9.0 |
| `@opentelemetry/propagator-jaeger` | npm | All versions | 2.9.0 |

## How do I fix CVE-2026-59892?

Upgrade @opentelemetry/propagator-jaeger to 2.9.0 or later.

## Is CVE-2026-59892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59892 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59892 and fix it if it is affected.

What it is: CVE-2026-59892 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-js, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59892 exists.

Affected packages and fixed versions:
- @opentelemetry/propagator-jaeger (npm): affected all versions; fixed in 2.9.0
- @opentelemetry/propagator-jaeger (npm): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59892/ (Markdown: https://insights.sbomify.com/CVE-2026-59892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59892
- OSV: https://osv.dev/vulnerability/CVE-2026-59892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59892/
Summaries are generated and may contain mistakes; the official description above is the record.
