# CVE-2026-59899: Netty HttpContentEncoder: Unbounded Per-Connection Queue Growth via HTTP/1.1 Pipelining Leads to Denial of Service


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** CLEANSTART-2026-BX32842, CLEANSTART-2026-DM42176, CLEANSTART-2026-EA53751, CLEANSTART-2026-LJ83599, CLEANSTART-2026-UQ38105, DEBIAN-CVE-2026-59899, ECHO-4b1e-5b94-dbf6, GHSA-q4f6-jm68-57ww, MINI-2f7q-c82g-94r6, MINI-2h5c-hcgx-j64p, MINI-3467-qqhw-4rg9, MINI-3582-p258-36mh, MINI-372c-ff3g-fmf8, MINI-38vv-2jfj-hqcx, MINI-39gm-pvpm-gfc2, MINI-3c63-9ww5-p54c, MINI-3fqq-6jf5-4xw4, MINI-3w93-252p-qcq8, MINI-3x9m-m57m-j3ph, MINI-454w-2qcc-hf99, MINI-4fmw-wvp6-f33p, MINI-4pgj-86hx-3mx9, MINI-4qgh-xwrm-m8g9, MINI-4rr3-8qvg-75rm, MINI-522c-fw5g-m5x5, MINI-52xr-h6rp-978v, MINI-55fq-9v2w-8vvp, MINI-57pp-fgj2-cm3c, MINI-5p8f-rgv3-h6jp, MINI-5pqw-jvqf-6rv6, MINI-5xxw-prw9-54j7, MINI-6489-g2jc-f7vq, MINI-65rh-qpx3-86j8, MINI-65vg-wq4p-pvw2, MINI-68pf-w5fr-2xrq, MINI-6h4j-q96h-6vx5, MINI-6h5j-43vv-xqc7, MINI-6h69-jq8c-6r7p, MINI-6rp8-qh28-fmhg, MINI-6rrv-v67p-2w2j, MINI-73xh-55gv-rcgf, MINI-75jp-m8qq-g7r7, MINI-75qp-97r3-pmv9, MINI-79v8-8m6q-pfx4, MINI-7g48-9rq3-v3pv, MINI-7pfm-vcrw-fprh, MINI-7rcq-2x24-5gv6, MINI-7v9f-m3gw-83rh, MINI-7vcw-gr7r-c5mm, MINI-825f-jg4f-fgj9, MINI-8gfc-fwhg-6r7p, MINI-8m86-4c75-7277, MINI-92xr-x9v4-ccmx, MINI-93pf-57hw-v8h7, MINI-94jf-pg7g-v6jw, MINI-98qw-276j-2fw9, MINI-c5w7-65qx-mp4r, MINI-cc37-v6fg-rwx9, MINI-cc8v-jqq9-3vhh, MINI-cmpp-qh63-rh3h, MINI-crhj-mh75-c44c, MINI-cv56-xrrc-m39x, MINI-f9xm-7jcq-fc5m, MINI-fpf5-cfjv-2jqm, MINI-fpr8-qcvg-62g8, MINI-g347-fwhg-h22h, MINI-g3q6-m9hw-7cxr, MINI-gfrm-3qxh-rj4f, MINI-h26c-hh6q-vrhf, MINI-h4jh-mhp6-335p, MINI-hv34-j2mq-m77w, MINI-j6rx-r7wh-47rx, MINI-jr98-vw93-fvr2, MINI-mqjr-f44f-f5xx, MINI-p4q2-jvq8-6xv5, MINI-p7v5-7mh3-g386, MINI-p832-85xw-mh2x, MINI-pg3q-qmfx-rxj7, MINI-pj2g-rpf2-xwf2, MINI-pmgf-92g4-x2pv, MINI-pw8h-gwqw-ff9q, MINI-pxwp-g88r-vp9p, MINI-q2cp-qxvv-5g66, MINI-q5r8-h2g7-vj2x, MINI-qq39-325f-jgv2, MINI-qwvj-25hv-93qq, MINI-qxpp-vpj4-ccx3, MINI-r693-chwg-gh2m, MINI-r6h4-979w-3prg, MINI-r862-x2fm-9c2r, MINI-rgp2-3prm-g2m2, MINI-rr3r-447m-4j54, MINI-rr64-q9v2-85fg, MINI-rx44-c9h9-3c29, MINI-v5f8-4g3v-2m4v, MINI-v7g8-7mcg-v352, MINI-v86v-m95q-vhwj, MINI-vh9f-8386-jjx5, MINI-vwq3-5hf4-rgr2, MINI-w4x2-2g8f-fw24, MINI-w645-jqrm-rfm7, MINI-w8v8-7c34-3rp7, MINI-w92g-v8m9-5qgm, MINI-wh62-9vff-8qxq, MINI-wpxf-p4q4-j7vh, MINI-wqh7-q7x6-q22g, MINI-x536-mm72-cp5r, MINI-x927-xx2r-mfw8, MINI-xcr3-7cgr-5qcx, MINI-xf99-grf7-vgjj, MINI-xmgc-2h55-f5hv, MINI-xwg6-w3gh-r7xx, MINI-xxc6-2qxw-jx5f, UBUNTU-CVE-2026-59899

## What is CVE-2026-59899?

CVE-2026-59899 is a medium-severity vulnerability in Netty Netty, published on 29 Jul 2026. 

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, `HttpContentEncoder` (the superclass of the production handler `HttpContentCompressor`) maintains a per-channel `ArrayDeque<CharSequence>` named `acceptEncodingQueue` that accumulates attacker-controlled data without any size limit. The queue is filled on the I/O thread for every inbound HTTP request and drained only when the application later writes a non-1xx response. This creates a resource exhaustion vulnerability when an attacker exploits HTTP/1.1 pipelining to flood the connection with requests faster than the application produces responses. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-59899?

4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-59899?

Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-59899 being exploited?

There is no known exploitation of CVE-2026-59899 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59899 and fix it if it is affected.

What it is: CVE-2026-59899 is a medium-severity vulnerability in Netty Netty, published on 29 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-59899 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59899/ (Markdown: https://insights.sbomify.com/CVE-2026-59899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59899
- OSV: https://osv.dev/vulnerability/CVE-2026-59899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59899/
Summaries are generated and may contain mistakes; the official description above is the record.
