# CVE-2026-59901: Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang

> Attackers can cause a denial of service by sending malformed bzip2 streams that hang the event-loop thread in Netty's Bzip2Decoder.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** CLEANSTART-2026-DK41558, CLEANSTART-2026-FG43911, CLEANSTART-2026-NQ53265, CLEANSTART-2026-OC34252, CLEANSTART-2026-TO73483, CLEANSTART-2026-XJ77136, DEBIAN-CVE-2026-59901, ECHO-5b55-d5ad-cc57, GHSA-558v-64gr-wgg4, MINI-248j-phw6-53jf, MINI-2744-p6f6-gcm5, MINI-2952-v8vq-6jxf, MINI-2c53-wx43-9vm6, MINI-2hrm-rv63-5qfx, MINI-2rgw-v7wv-fv8x, MINI-2v83-8pm6-jrqg, MINI-2xxh-gx28-9jgj, MINI-375q-28v6-4477, MINI-3gff-g564-p7x4, MINI-3hhr-6pw9-mjmv, MINI-3jwg-fjwf-927f, MINI-3rq7-3m42-w9rm, MINI-435j-rfhj-rgj2, MINI-4h9g-mffm-p6mf, MINI-4q73-g9c3-fq83, MINI-544p-ff8g-c437, MINI-55qc-ccvx-8r29, MINI-5c4g-c56m-mh87, MINI-5fm2-vhxc-hh6q, MINI-5h6g-p3rf-vr57, MINI-5m78-gfh3-cfj9, MINI-66ff-pwgp-hpjr, MINI-6f5q-hwrr-c994, MINI-6gqr-7mmx-x2wr, MINI-6mfc-h745-f78r, MINI-6x7g-fqcv-4gw9, MINI-73fw-g8fv-76x2, MINI-74vf-47w7-vhcx, MINI-78w6-6pwg-47ff, MINI-7933-w3jr-wf9g, MINI-7gjf-pv2m-9fw3, MINI-7jcv-vjf9-hggf, MINI-7rh4-36q6-26jp, MINI-7xq6-ph27-cc6f, MINI-842w-ppvf-jw5g, MINI-8g83-6g6q-jvfx, MINI-8gw6-7fq6-fhff, MINI-8jfq-x7w7-2fvf, MINI-8mxr-f2x3-ff99, MINI-8q75-h8qw-2hfh, MINI-8q87-px9x-xc72, MINI-8v43-qf33-72gx, MINI-988c-vgqm-m8j2, MINI-9jv8-w248-v3j2, MINI-c7c3-36wj-h8fr, MINI-cfjx-6rg9-r85w, MINI-cxg4-743c-985x, MINI-f7wj-xv5f-phx7, MINI-fg8p-xw46-j53r, MINI-frqh-fgg7-h94x, MINI-fx8v-p7cr-9w28, MINI-g226-wfr5-m4fv, MINI-g3pj-7c3f-rmhg, MINI-g4rh-2q7h-j958, MINI-gf7f-7gjm-wr8p, MINI-gfpc-6rmq-6cqr, MINI-ggwc-45g6-2jjq, MINI-gj9q-c3vm-jw78, MINI-h3gv-r5c8-9v45, MINI-h792-f882-hvp6, MINI-h9fp-86g6-6wqq, MINI-h9gw-qf84-7p52, MINI-hcc8-p3g9-rghj, MINI-hjr7-fmmm-p6fx, MINI-hqj5-chf3-j3g7, MINI-j5mm-fqxv-pxv2, MINI-j675-ghxf-8qv2, MINI-jj78-v937-q4mc, MINI-m4mf-jg92-2hvf, MINI-m52v-h677-295p, MINI-m5jg-79j5-8f9v, MINI-m5xp-r3q4-vvv5, MINI-m87m-vg8v-gxgm, MINI-mf2q-hqwf-8g2j, MINI-mg92-4c3j-5qpx, MINI-mhx3-w537-m42w, MINI-mhx6-96hv-3jxc, MINI-mvq9-qv5j-xw3m, MINI-mw6j-jg6h-xv8x, MINI-p39r-g93p-3pff, MINI-p696-cx3c-4cc3, MINI-phqh-53f9-79fj, MINI-pj62-pp89-xh5j, MINI-pm25-mwp9-8xfr, MINI-q28g-qhf2-rxrh, MINI-q5c3-gm2w-9739, MINI-q5cw-2x85-w75p, MINI-q6fw-rh4r-p7m2, MINI-q7qq-9j7j-xgfh, MINI-qcj4-v53q-p57f, MINI-qg99-29vv-v45q, MINI-qh2c-j4j5-mwfp, MINI-r87g-gf3h-j5g3, MINI-rjmw-2qp2-63xq, MINI-rjwr-f7gv-pw83, MINI-rr6f-54v7-f863, MINI-rrjr-77wf-23j9, MINI-rrr4-4m63-6f8c, MINI-rx37-3735-pq4p, MINI-v5gg-76x2-q33x, MINI-v97x-r48v-6f2p, MINI-vfg9-x32j-34qj, MINI-vjh3-8cfg-6fpm, MINI-vqmp-9pcg-28ch, MINI-vwmw-4phh-h4mh, MINI-w456-p36v-cp2m, MINI-wgpx-q4xh-pggh, MINI-x526-fm5q-rgj8, MINI-x5gc-8j99-42g3, MINI-x69c-v7fh-cx27, MINI-x6h8-8ppq-4cv2, MINI-x8jh-773p-gfpx, MINI-x8rr-xjc2-gg7r, MINI-xqx5-3jv7-47q6, ROOT-APP-MAVEN-CVE-2026-59901, UBUNTU-CVE-2026-59901

## What is CVE-2026-59901?

CVE-2026-59901 is a high-severity denial of service vulnerability in Netty Netty, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the `Bzip2Decoder` handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the event-loop thread in an infinite loop. The vulnerability exists in the run-length encoding (RLE) state machine within [`Bzip2BlockDecompressor.read()`]. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-59901?

4 open source packages ship an affected version, including io.netty:netty-codec and io.netty:netty-codec-compression. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-compression` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-compression` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-59901?

Upgrade io.netty:netty-codec to 4.1.136.Final or later.

## Is CVE-2026-59901 being exploited?

There is no known exploitation of CVE-2026-59901 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)
- [CVE-2026-45674](https://insights.sbomify.com/CVE-2026-45674/): Netty Vulnerable to DNS Cache Poisoning via Missing Bailiwick Checks in CNAME Records (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59901 and fix it if it is affected.

What it is: CVE-2026-59901 is a high-severity denial of service vulnerability in Netty Netty, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59901 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-compression (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-compression (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59901/ (Markdown: https://insights.sbomify.com/CVE-2026-59901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59901
- OSV: https://osv.dev/vulnerability/CVE-2026-59901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59901/
Summaries are generated and may contain mistakes; the official description above is the record.
