# CVE-2026-59920: Netty: STOMP CONNECT Frame Header Injection

> Attackers can inject STOMP headers via unescaped newlines in CONNECT frames, potentially bypassing authentication or escalating privileges in dependent brokers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** CLEANSTART-2026-AJ11768, CLEANSTART-2026-RY69809, DEBIAN-CVE-2026-59920, GHSA-3g8r-4pfx-jmfh, MINI-239w-wv4f-px8c, MINI-6cp6-8g86-4jjh, MINI-6mq3-h469-ff72, MINI-6vxw-ggmx-fffj, MINI-7rx4-6ffc-447x, MINI-8xjx-2v8f-8253, MINI-9g87-2g49-hx58, MINI-gf84-382r-x6w7, MINI-gh8c-855c-4q5q, MINI-h57j-xcmw-hhp2, UBUNTU-CVE-2026-59920

## What is CVE-2026-59920?

CVE-2026-59920 is a medium-severity vulnerability in Netty Netty, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.136.Final and 4.2.16.Final, Netty's STOMP encoder ( StompSubframeEncoder ) does not escape or validate header values in  CONNECT  and  CONNECTED  frames, so raw newline ( \n ) characters in a header value are written directly to the wire, allowing an attacker who controls a header value to inject additional STOMP headers. This happens because the encoder intentionally skips escaping for CONNECT/CONNECTED frames per the STOMP 1.2 specification but never rejects the raw newlines, and since a broker parses each line as a separate header, an attacker controlling a value such as a user-supplied login or passcode can overwrite connection parameters or add authentication/role headers to bypass authentication or escalate privileges (the actual impact is broker-dependent). The issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-59920?

4 open source packages ship an affected version, including io.netty:netty-codec-stomp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-stomp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-stomp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-stomp` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-stomp` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-59920?

Upgrade io.netty:netty-codec-stomp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-59920 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59920 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59920 and fix it if it is affected.

What it is: CVE-2026-59920 is a medium-severity vulnerability in Netty Netty, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59920 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-stomp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-stomp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-stomp (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-stomp (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59920/ (Markdown: https://insights.sbomify.com/CVE-2026-59920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59920
- OSV: https://osv.dev/vulnerability/CVE-2026-59920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59920/
Summaries are generated and may contain mistakes; the official description above is the record.
