# CVE-2026-59930: Mistune toc / TableOfContents directive: heading IDs use predictable `toc_N` numbering with no slugification, allowing collision with attacker-controlled `id="toc_N"` content

> Predictable heading IDs in Mistune allow attackers to collide anchors, potentially redirecting navigation or bypassing security checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** AZL-92223, DEBIAN-CVE-2026-59930, ECHO-1288-ebec-bb75, GHSA-2hm2-hc3v-44h9, PYSEC-2026-2218, UBUNTU-CVE-2026-59930

## What is CVE-2026-59930?

CVE-2026-59930 is a medium-severity vulnerability in lepture mistune, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.3.0, the toc plugin and TableOfContents directive generate heading IDs as predictable toc_N values without slugifying the heading text, allowing attacker-controlled id="toc_N" content to collide with generated anchors and redirect same-page navigation, CSS selectors, or JavaScript handlers. This issue is fixed in version 3.3.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-59930?

3 open source packages ship an affected version, including mistune. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistune` | PyPI | All versions | 3.3.0 |
| `mistune` | PyPI | All versions | 3.3.0 |
| `mistune` | PyPI | All versions | 3.3.0 |

Products: Mistune Project Mistune.

## How do I fix CVE-2026-59930?

Upgrade mistune to 3.3.0 or later.

## Is CVE-2026-59930 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59930 exists.

## Other vulnerabilities in lepture mistune

- [CVE-2026-59922](https://insights.sbomify.com/CVE-2026-59922/): Mistune plugins/formatting: quadratic-time parsing on long runs of `~~x~~`, `==x==`, and `^^x^^` markers (strikethrough / mark / insert) (high 7.5)
- [CVE-2026-59925](https://insights.sbomify.com/CVE-2026-59925/): inline_parser: quadratic-time parsing on long runs of `**x**` and `***x***` emphasis pairs (high 7.5)
- [CVE-2026-59928](https://insights.sbomify.com/CVE-2026-59928/): Mistune block_parser: quadratic-time parsing on long lists of repeated reference-link definitions (high 7.5)
- [CVE-2026-59923](https://insights.sbomify.com/CVE-2026-59923/): Mistune: XSS via percent-encoded javascript URI bypass in safe_url() (medium 6.1)
- [CVE-2026-59929](https://insights.sbomify.com/CVE-2026-59929/): Mistune renderers/html.safe_url: HARMFUL_PROTOCOLS list misses legacy and chained schemes that historically chain to `javascript:` execution (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59930 and fix it if it is affected.

What it is: CVE-2026-59930 is a medium-severity vulnerability in lepture mistune, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59930 exists.

Affected packages and fixed versions:
- mistune (PyPI): affected all versions; fixed in 3.3.0
- mistune (PyPI): affected all versions; fixed in 3.3.0
- mistune (PyPI): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59930/ (Markdown: https://insights.sbomify.com/CVE-2026-59930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59930
- OSV: https://osv.dev/vulnerability/CVE-2026-59930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59930/
Summaries are generated and may contain mistakes; the official description above is the record.
