# CVE-2026-59931: PhpSpreadsheet: SSRF bypass via HTTP redirect in WEBSERVICE() domain whitelist

> Attackers can bypass domain whitelists in PhpSpreadsheet via HTTP redirects to perform Server-Side Request Forgery, accessing internal services and cloud metadata.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-6hq5-7373-42rg

## What is CVE-2026-59931?

CVE-2026-59931 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the WEBSERVICE() domain whitelist can be bypassed via an HTTP redirect (SSRF). In Calculation/Web/Service.php, the webService() method validates a URL's host against the whitelist set via Spreadsheet::setDomainWhiteList(), then fetches content with file_get_contents($url, false, $ctx); because PHP's HTTP stream wrapper follows 301/302 redirects automatically (up to 20 hops) and the redirect target is never re-validated, an attacker who can trigger a redirect from a whitelisted domain can reach arbitrary URLs, including internal addresses. An attacker able to upload XLSX files to an application that uses setDomainWhiteList() and getCalculatedValue() can achieve a full-read SSRF, returning up to 32,767 bytes of the response body as a cell's calculated value, which enables exfiltration of cloud metadata (AWS/GCP/Azure credentials via http://169.254.169.254/), access to internal-only services, and internal port scanning (the port is not validated). This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18, and 1.30.6.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-59931?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.6 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.6 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.18 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.18 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.8.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.8.1 |

## How do I fix CVE-2026-59931?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.6, 2.1.18, 2.4.7 or 3.10.7.

## Is CVE-2026-59931 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59931 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59931 and fix it if it is affected.

What it is: CVE-2026-59931 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59931 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59931/ (Markdown: https://insights.sbomify.com/CVE-2026-59931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59931
- OSV: https://osv.dev/vulnerability/CVE-2026-59931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59931/
Summaries are generated and may contain mistakes; the official description above is the record.
