{"answers":{"affected":"10 open source packages ship an affected version, including phpoffice/phpspreadsheet.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59932 exists.","fix":"Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.6, 2.1.18, 2.4.7 or 3.10.7.","what":"CVE-2026-59932 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59932 and fix it if it is affected.\n\nWhat it is: CVE-2026-59932 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59932 exists.\n\nAffected packages and fixed versions:\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7\n- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7\n- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7\n- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1\n- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59932/ (Markdown: https://insights.sbomify.com/CVE-2026-59932/index.md)","id":"CVE-2026-59932","markdown":"https://insights.sbomify.com/CVE-2026-59932/index.md","name":"CVE-2026-59932","record":{"aliases":["GHSA-2mrg-gjxq-2gvr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"none","summary":"Attackers can cause denial of service by uploading small gzip-compressed Gnumeric files that expand to exhaust memory during parsing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18 and 1.30.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PhpSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion","id":"CVE-2026-59932","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":10,"n_references":7,"next":{"headline":"PhpSpreadsheet: XLS/OLE sector-chain self-loop causes memory exhaustion","id":"CVE-2026-59933"},"packages":[{"ecosystem":"Packagist","fixed":["1.30.6"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["1.30.6"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["2.1.18"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["2.1.18"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["2.4.7"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["2.4.7"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["3.10.7"],"introduced":["3.3.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["3.10.7"],"introduced":["3.3.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["5.8.1"],"introduced":["4.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-2mrg-gjxq-2gvr"},{"ecosystem":"Packagist","fixed":["5.8.1"],"introduced":["4.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-2mrg-gjxq-2gvr"}],"prev":{"headline":"PhpSpreadsheet: SSRF bypass via HTTP redirect in WEBSERVICE() domain whitelist","id":"CVE-2026-59931"},"products":["PhpSpreadsheet"],"published":"2026-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["PHPOffice"]},"summary":"Attackers can cause denial of service by uploading small gzip-compressed Gnumeric files that expand to exhaust memory during parsing.","url":"https://insights.sbomify.com/CVE-2026-59932/"}