# CVE-2026-59932: PhpSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion

> Attackers can cause denial of service by uploading small gzip-compressed Gnumeric files that expand to exhaust memory during parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-2mrg-gjxq-2gvr

## What is CVE-2026-59932?

CVE-2026-59932 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18 and 1.30.6.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59932?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.6 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.6 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.18 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.18 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.8.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.8.1 |

## How do I fix CVE-2026-59932?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.6, 2.1.18, 2.4.7 or 3.10.7.

## Is CVE-2026-59932 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59932 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59932 and fix it if it is affected.

What it is: CVE-2026-59932 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59932 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.6
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.18
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.7
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.7
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59932/ (Markdown: https://insights.sbomify.com/CVE-2026-59932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59932
- OSV: https://osv.dev/vulnerability/CVE-2026-59932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59932/
Summaries are generated and may contain mistakes; the official description above is the record.
