# CVE-2026-59939: httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 20 Aug 2026
- **Also known as:** ALSA-2026:47736, ALSA-2026:48585, ALSA-2026:50317, AZL-92295, CLEANSTART-2026-HU27522, DEBIAN-CVE-2026-59939, ECHO-ccad-6619-0a54, GHSA-j5g9-f88f-gfj3, MGASA-2026-0419, MINI-g3pf-2cvf-pv8r, MINI-gg23-jx47-35mf, MINI-j74f-4p54-jgpv, MINI-wjpq-9w9v-x65p, PYSEC-2026-3444, RHSA-2026:47736, RHSA-2026:48585, RHSA-2026:48604, RHSA-2026:48605, RHSA-2026:48615, RHSA-2026:49911, RHSA-2026:50317, RHSA-2026:50653, RHSA-2026:50654, RHSA-2026:50655, RLSA-2026:47736, RLSA-2026:48585, RLSA-2026:50317, ROOT-APP-PYPI-CVE-2026-59939, SUSE-SU-2026:23120-1, SUSE-SU-2026:23142-1, SUSE-SU-2026:3898-1, UBUNTU-CVE-2026-59939, USN-8537-1, openSUSE-SU-2026:21526-1

## What is CVE-2026-59939?

CVE-2026-59939 is a high-severity vulnerability in httplib2, published on 8 Jul 2026. 

### Official description

httplib2 is a comprehensive HTTP client library for Python. Prior to 0.32.0, httplib2 performs unbounded decompression of HTTP response bodies encoded with Content-Encoding: gzip or deflate in _decompressContent in httplib2/init.py, allowing a malicious or compromised HTTP server to return a small compressed payload that expands to an arbitrarily large size in memory and causes MemoryError or OOM-kill in the client process. This issue is fixed in version 0.32.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-59939?

3 open source packages ship an affected version, including httplib2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httplib2` | PyPI | All versions | 0.32.0 |
| `httplib2` | PyPI | All versions | 0.32.0 |
| `httplib2` | PyPI | All versions | 0.32.0 |
| `fence-agents-aliyun` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-all` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-amt-ws` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-apc` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-apc-snmp` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-aws` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-azure-arm` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-bladecenter` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-brocade` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-cisco-mds` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-cisco-ucs` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-common` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-drac5` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-eaton-snmp` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-emerson` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-eps` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-gce` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-heuristics-ping` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-hpblade` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ibm-powervs` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ibm-vpc` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ibmblade` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ifmib` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ilo-moonshot` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ilo-mp` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ilo-ssh` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ilo2` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-intelmodular` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ipdu` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-ipmilan` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-kdump` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-kubevirt` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-lpar` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-mpath` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-nutanix-ahv` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-openstack` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |
| `fence-agents-redfish` | AlmaLinux:10 | All versions | 4.16.0-21.el10_2.5 |

Products: Httplib2 Project Httplib2.

## How do I fix CVE-2026-59939?

Upgrade httplib2 to 0.32.0 or later.

## Is CVE-2026-59939 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59939 exists.

## Other vulnerabilities in httplib2

- [CVE-2021-21240](https://insights.sbomify.com/CVE-2021-21240/): Regular Expression Denial of Service in httplib2 (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59939 and fix it if it is affected.

What it is: CVE-2026-59939 is a high-severity vulnerability in httplib2, published on 8 Jul 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59939 exists.

Affected packages and fixed versions:
- httplib2 (PyPI): affected all versions; fixed in 0.32.0
- httplib2 (PyPI): affected all versions; fixed in 0.32.0
- httplib2 (PyPI): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59939/ (Markdown: https://insights.sbomify.com/CVE-2026-59939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59939
- OSV: https://osv.dev/vulnerability/CVE-2026-59939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59939/
Summaries are generated and may contain mistakes; the official description above is the record.
