# CVE-2026-59940: seroval: `seroval.fromJSON()` Promise resolver type confusion invokes attacker-controlled methods during deserialization

> Attacker-controlled JSON can trigger unintended method invocations during deserialization, potentially leading to remote code execution in applications using seroval with plugins.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-mv8w-475r-vwqw, ROOT-APP-NPM-CVE-2026-59940

## What is CVE-2026-59940?

CVE-2026-59940 is a critical unsafe deserialization vulnerability in lxsmnsyc seroval, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. Prior to 1.5.3, seroval.fromJSON() allows attacker-controlled JSON Promise control nodes to operate on values from the general deserialization reference table without verifying genuine internal Promise resolver records, causing deserialization side effects with plugins enabled and potentially unintended server-side invocation or remote code execution when downstream frameworks register callable wrappers. This issue is fixed in version 1.5.3.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-59940?

2 open source packages ship an affected version, including seroval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | All versions | 1.5.3 |
| `seroval` | npm | All versions | 1.5.3 |

## How do I fix CVE-2026-59940?

Upgrade seroval to 1.5.3 or later.

## Is CVE-2026-59940 being exploited?

There is no known exploitation of CVE-2026-59940 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59940 and fix it if it is affected.

What it is: CVE-2026-59940 is a critical unsafe deserialization vulnerability in lxsmnsyc seroval, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59940 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected all versions; fixed in 1.5.3
- seroval (npm): affected all versions; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59940/ (Markdown: https://insights.sbomify.com/CVE-2026-59940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59940
- OSV: https://osv.dev/vulnerability/CVE-2026-59940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59940/
Summaries are generated and may contain mistakes; the official description above is the record.
