# CVE-2026-59941: Dompdf: Uncontrolled resource consumption based on declared BMP dimensions

> Attacker can cause excessive memory and CPU consumption via crafted BMP images in HTML, leading to denial of service in Dompdf.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-59941, GHSA-8hg6-c449-896m, UBUNTU-CVE-2026-59941

## What is CVE-2026-59941?

CVE-2026-59941 is a medium-severity denial of service vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior accept a BMP image and generates a PDF-compatible PNG based only on its declared header dimensions and never bounds width × height before the image is converted through GD. A 58-byte BMP whose header declares e.g. 6000×6000 is accepted and later drives imagecreatetruecolor($width, $height) (and PHP's native BMP decoder) to allocate the full pixel canvas. A payload can fit in a single HTTP request: the BMP can be inlined as a data:image/bmp;base64,… URI inside attacker-controlled HTML, so no upload, no remote fetch, and no chroot-reachable file is required. I measured a 169-byte request driving a dompdf render to ~412 MB peak RSS and ~4.8 s of CPU/wall time, versus ~34 MB for an identically-sized benign request — roughly a 12× memory amplification per request, repeatable and unauthenticated. This issue has been fixed in version 3.16.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59941?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2026-59941?

Upgrade dompdf/dompdf to 3.1.6 or later.

## Is CVE-2026-59941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59941 exists.

Public exploit code:

- Dompdf: Denial of Service (DoS) via Resource Exhaustion using Oversized Image Bitmaps (github_poc): https://github.com/far00t01/CVE-2026-59941

## Other vulnerabilities in dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59941 and fix it if it is affected.

What it is: CVE-2026-59941 is a medium-severity denial of service vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59941 exists.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59941/ (Markdown: https://insights.sbomify.com/CVE-2026-59941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59941
- OSV: https://osv.dev/vulnerability/CVE-2026-59941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59941/
Summaries are generated and may contain mistakes; the official description above is the record.
