# CVE-2026-59942: Dompdf: Denial of Service (DoS) via Resource Exhaustion using Oversized Image Bitmaps

> An attacker can crash the PHP process by submitting a crafted HTML document with oversized images, causing a Denial of Service.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-59942, GHSA-f5gf-2cj8-52g2, UBUNTU-CVE-2026-59942

## What is CVE-2026-59942?

CVE-2026-59942 is a medium-severity denial of service vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a Denial of Service (DoS) attack via resource exhaustion. An attacker can crash the PHP process by providing a specially crafted HTML document containing a single image with massive dimensions (e.g., 30,000x30,000 pixels). While Dompdf implements internal checks to validate image dimensions, these can be bypassed by using a high-entropy image (such as random noise) encoded in Base64 and wrapped in specific CSS containers. The vulnerability exists because the dimension validation happens early, but the resource allocation for calculating the object's bounding box and internal buffers during the rendering phase does not strictly limit the cumulative CPU time or memory usage for a single object that has passed the initial check. An unauthenticated remote attacker can cause a complete Denial of Service on the web server by submitting a crafted HTML string. This affects any application that allows users to provide HTML content or URLs that are subsequently converted to PDF using Dompdf. This issue has been fixed in version 3.16.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59942?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2026-59942?

Upgrade dompdf/dompdf to 3.1.6 or later.

## Is CVE-2026-59942 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59942 exists.

## Other vulnerabilities in dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59942 and fix it if it is affected.

What it is: CVE-2026-59942 is a medium-severity denial of service vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59942 exists.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59942/ (Markdown: https://insights.sbomify.com/CVE-2026-59942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59942
- OSV: https://osv.dev/vulnerability/CVE-2026-59942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59942/
Summaries are generated and may contain mistakes; the official description above is the record.
