# CVE-2026-59946: Composer: Path traversal in package bin field lets dependencies chmod arbitrary host files

> A malicious Composer package can use path traversal in its bin field to chmod arbitrary host files, potentially leading to privilege escalation or data modification.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-composer-2026-59946, CLEANSTART-2026-XS00515, DEBIAN-CVE-2026-59946, GHSA-gjfg-22fp-rrxx, MINI-2x76-2c3f-vphj, MINI-xvgc-rq86-jjv9, RHSA-2026:34854, UBUNTU-CVE-2026-59946

## What is CVE-2026-59946?

CVE-2026-59946 is a medium-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a Composer package bin entry containing .. path segments can resolve outside the package install directory and cause Composer's binary installation flow to chmod an existing host file to a world-readable and world-executable mode during composer install, update, or require. This issue is fixed in versions 2.2.29 and 2.10.2.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59946?

5 open source packages ship an affected version, including composer/composer and composer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.29 |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.29 |
| `composer/composer` | Packagist | From 2.3.0 | 2.10.2 |
| `composer/composer` | Packagist | From 2.3.0 | 2.10.2 |
| `composer` | Bitnami | From 1.0.0 | 2.2.29, 2.10.2 |
| `composer` | Red Hat:hummingbird:1 | All versions | 0:2.10.2-1.hum1 |

## How do I fix CVE-2026-59946?

Upgrade composer/composer to a fixed version for your release line: 2.2.29 or 2.10.2.

## Is CVE-2026-59946 being exploited?

There is no known exploitation of CVE-2026-59946 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59946 and fix it if it is affected.

What it is: CVE-2026-59946 is a medium-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59946 in the wild and no public exploit code.

Affected packages and fixed versions:
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2
- composer (Bitnami): affected from 1.0.0; fixed in 2.2.29, 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59946/ (Markdown: https://insights.sbomify.com/CVE-2026-59946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59946
- OSV: https://osv.dev/vulnerability/CVE-2026-59946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59946/
Summaries are generated and may contain mistakes; the official description above is the record.
