{"answers":{"affected":"5 open source packages ship an affected version, including composer/composer and composer.","exploited":"There is no known exploitation of CVE-2026-59948 in the wild and no public exploit code.","fix":"Upgrade composer/composer to a fixed version for your release line: 2.2.29 or 2.10.2.","what":"CVE-2026-59948 is a high-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-59948 and fix it if it is affected.\n\nWhat it is: CVE-2026-59948 is a high-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-59948 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29\n- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29\n- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2\n- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2\n- composer (Bitnami): affected from 1.0.0; fixed in 2.2.29, 2.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59948/ (Markdown: https://insights.sbomify.com/CVE-2026-59948/index.md)","id":"CVE-2026-59948","markdown":"https://insights.sbomify.com/CVE-2026-59948/index.md","name":"CVE-2026-59948","record":{"aliases":["BIT-composer-2026-59948","CLEANSTART-2026-UO36556","DEBIAN-CVE-2026-59948","GHSA-499r-g7pc-vmp9","MINI-9g3c-8rrh-6xvc","MINI-mjgq-whqr-q4w2","UBUNTU-CVE-2026-59948"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"PHP dependency manager","requires_auth":"none","summary":"Attackers can write arbitrary files outside the vendor directory via malicious package names, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Composer: Arbitrary file write outside vendor via malicious transitive package name","id":"CVE-2026-59948","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":5,"n_references":5,"next":{"headline":"LZ4 Java: Native XXHash implementations can crash the JVM when passed invalid byte array ranges","id":"CVE-2026-59949"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.29","2.10.2"],"introduced":["1.0.0","2.3.0"],"last_affected":[],"package":"composer","purl":"pkg:bitnami/composer","source":"BIT-composer-2026-59948"},{"ecosystem":"Packagist","fixed":["2.2.29"],"introduced":["1.0.0"],"last_affected":[],"package":"composer/composer","purl":null,"source":"GHSA-499r-g7pc-vmp9"},{"ecosystem":"Packagist","fixed":["2.2.29"],"introduced":["1.0.0"],"last_affected":[],"package":"composer/composer","purl":"pkg:composer/composer/composer","source":"GHSA-499r-g7pc-vmp9"},{"ecosystem":"Packagist","fixed":["2.10.2"],"introduced":["2.3.0"],"last_affected":[],"package":"composer/composer","purl":null,"source":"GHSA-499r-g7pc-vmp9"},{"ecosystem":"Packagist","fixed":["2.10.2"],"introduced":["2.3.0"],"last_affected":[],"package":"composer/composer","purl":"pkg:composer/composer/composer","source":"GHSA-499r-g7pc-vmp9"}],"prev":{"headline":"Composer: URL-embedded HTTP-Basic username leaks to verbose logs (GitHub PAT exposure)","id":"CVE-2026-59947"},"products":["composer"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["composer"]},"summary":"Attackers can write arbitrary files outside the vendor directory via malicious package names, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-59948/"}