# CVE-2026-59948: Composer: Arbitrary file write outside vendor via malicious transitive package name

> Attackers can write arbitrary files outside the vendor directory via malicious package names, potentially leading to code execution.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-composer-2026-59948, CLEANSTART-2026-UO36556, DEBIAN-CVE-2026-59948, GHSA-499r-g7pc-vmp9, MINI-9g3c-8rrh-6xvc, MINI-mjgq-whqr-q4w2, UBUNTU-CVE-2026-59948

## What is CVE-2026-59948?

CVE-2026-59948 is a high-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

Weakness: CWE-787 (Out-of-bounds Write), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59948?

5 open source packages ship an affected version, including composer/composer and composer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.29 |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.29 |
| `composer/composer` | Packagist | From 2.3.0 | 2.10.2 |
| `composer/composer` | Packagist | From 2.3.0 | 2.10.2 |
| `composer` | Bitnami | From 1.0.0 | 2.2.29, 2.10.2 |

## How do I fix CVE-2026-59948?

Upgrade composer/composer to a fixed version for your release line: 2.2.29 or 2.10.2.

## Is CVE-2026-59948 being exploited?

There is no known exploitation of CVE-2026-59948 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59948 and fix it if it is affected.

What it is: CVE-2026-59948 is a high-severity path traversal vulnerability in composer, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59948 in the wild and no public exploit code.

Affected packages and fixed versions:
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.29
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.10.2
- composer (Bitnami): affected from 1.0.0; fixed in 2.2.29, 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59948/ (Markdown: https://insights.sbomify.com/CVE-2026-59948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59948
- OSV: https://osv.dev/vulnerability/CVE-2026-59948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59948/
Summaries are generated and may contain mistakes; the official description above is the record.
