# CVE-2026-59949: LZ4 Java: Native XXHash implementations can crash the JVM when passed invalid byte array ranges

> Attackers can crash the JVM by passing null arrays or invalid ranges to JNI-backed XXHash functions in the lz4-java library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** CLEANSTART-2026-GP40817, CLEANSTART-2026-IG77090, CLEANSTART-2026-JC19779, CLEANSTART-2026-LJ57058, CLEANSTART-2026-MY27015, CLEANSTART-2026-UF96774, CLEANSTART-2026-ZA82538, CLSA-2026-1788330944, DEBIAN-CVE-2026-59949, ECHO-b1ea-8488-dc14, GHSA-xx22-p4ch-683r, MINI-2w87-vcgc-f82g, MINI-3h82-4mrq-2mff, MINI-3hr3-prfg-24mg, MINI-3mh9-8x2v-gcx9, MINI-3q89-pqr6-8fwm, MINI-433w-hh3p-43wr, MINI-44cq-39v7-f3xm, MINI-4fhj-rf6p-8wmc, MINI-4gjp-9x7j-63r5, MINI-4p3x-93f8-4mm9, MINI-4rpg-fc38-8cfm, MINI-4wcc-j363-g7m7, MINI-53vh-phmv-93mp, MINI-5gw2-gqm7-r77p, MINI-5vqw-8pxx-65jc, MINI-7464-g75m-qf5h, MINI-78v9-q96x-3p67, MINI-7q46-wvj7-xhqx, MINI-8gvm-8qqr-5979, MINI-973g-3pw4-m7hj, MINI-976j-3q4w-xx5c, MINI-98xq-hcvg-7hvp, MINI-9g2v-5j46-jg9j, MINI-9hgj-46hq-f429, MINI-9v46-p655-j2qx, MINI-9vpp-g728-6qgg, MINI-cmpj-5p29-cjpx, MINI-frwv-5w7x-8wgq, MINI-g6q3-crcr-3xcr, MINI-gjwg-9vp7-x23h, MINI-gxj3-w659-jhwr, MINI-h8j2-wq66-jgm8, MINI-h9m6-425c-cmr5, MINI-hchp-q6fh-xgm4, MINI-hqqg-8cp2-x7pq, MINI-jf28-mh45-763r, MINI-jp7r-xvp4-3pvc, MINI-jrjr-j3m2-6j9c, MINI-jw3c-p5p6-mf8m, MINI-jw9c-7v3c-6475, MINI-m253-v269-jjmj, MINI-m44g-cxhv-j2f3, MINI-m5gm-cp27-p5vr, MINI-mjgf-6232-prhj, MINI-mv2c-76j3-8395, MINI-p763-676c-f5m5, MINI-pmf7-wm85-9xqm, MINI-pp6x-hr5f-4jj6, MINI-q82q-3774-59fr, MINI-q8m7-fmp8-p36h, MINI-qf3h-j824-h8cj, MINI-r5vm-j3pv-9736, MINI-r8p4-v898-c9x2, MINI-r9j5-vg96-c3hc, MINI-rvcg-wc8h-7j6h, MINI-vpwj-rwjv-pmr8, MINI-vw75-mh42-mj9g, MINI-wq9c-gfmx-wwg5, MINI-wr9g-38w4-v33h, MINI-x24x-84q9-vccp, MINI-x34j-5mmv-6wcp, MINI-x47h-44vx-335c, MINI-x744-27r3-223m, MINI-xfhx-m33g-43wh, MINI-xmm7-wfw5-p6cx, OESA-2026-4077, OESA-2026-4078, OESA-2026-4079, UBUNTU-CVE-2026-59949

## What is CVE-2026-59949?

CVE-2026-59949 is a medium-severity vulnerability in yawkat lz4-java, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.1, JNI-backed XXHash implementations fail to validate the byte array object and the off and len arguments in XXHashFactory.nativeInstance().hash32().hash(), XXHashFactory.nativeInstance().hash64().hash(), XXHashFactory.nativeInstance().newStreamingHash32().update(), and XXHashFactory.nativeInstance().newStreamingHash64().update(), allowing null arrays or oversized ranges to reach native code, read outside the Java array, and fatally terminate the JVM. This issue is fixed in version 1.11.1.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-59949?

4 open source packages ship an affected version, including at.yawk.lz4:lz4-java and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.1 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.11.1 |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |

## How do I fix CVE-2026-59949?

Upgrade at.yawk.lz4:lz4-java to 1.11.1 or later.

## Is CVE-2026-59949 being exploited?

There is no known exploitation of CVE-2026-59949 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59949 and fix it if it is affected.

What it is: CVE-2026-59949 is a medium-severity vulnerability in yawkat lz4-java, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59949 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.1
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.11.1
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59949/ (Markdown: https://insights.sbomify.com/CVE-2026-59949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59949
- OSV: https://osv.dev/vulnerability/CVE-2026-59949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59949/
Summaries are generated and may contain mistakes; the official description above is the record.
