# CVE-2026-59955: Apollo ConfigService access key authentication bypass via raw config file appId parsing

> Attackers can bypass authentication to read raw configuration data in Apollo ConfigService when AccessKey authentication is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-h4pc-58cc-hc95

## What is CVE-2026-59955?

CVE-2026-59955 is a high-severity authentication bypass vulnerability in apolloconfig apollo, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo is a reliable configuration management system suitable for microservice configuration management scenarios. Prior to 2.5.2, Apollo ConfigService may allow unauthorized access to raw configuration data when AccessKey or management key authentication is enabled because requests under /configfiles/raw/{appId}/{clusterName}/{namespace} are parsed for authentication as appId raw instead of the actual path appId, causing ConfigService to look up AccessKey secrets for raw before verifying the request signature and potentially continue without signature verification for the target appId. This issue is fixed in version 2.5.2.

Weakness: CWE-287 (Improper Authentication), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-59955?

2 open source packages ship an affected version, including com.ctrip.framework.apollo:apollo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | None |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | None |

## How do I fix CVE-2026-59955?

No fix has been published for CVE-2026-59955 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59955 being exploited?

There is no known exploitation of CVE-2026-59955 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59955 and fix it if it is affected.

What it is: CVE-2026-59955 is a high-severity authentication bypass vulnerability in apolloconfig apollo, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59955 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; no fix listed
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59955/ (Markdown: https://insights.sbomify.com/CVE-2026-59955/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59955
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59955
- OSV: https://osv.dev/vulnerability/CVE-2026-59955

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59955/
Summaries are generated and may contain mistakes; the official description above is the record.
