CVE-2026-59965 @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission

High 7.1 Published Updated

An authenticated low-privilege user can bypass access controls to read and modify protected upload documents in Payload CMS via the alt-text plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59965?

CVE-2026-59965 is a high-severity missing authorization vulnerability in @jhb.software payload-alt-text-plugin, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.

Weakness: CWE-863

Which versions are affected by CVE-2026-59965?

2 open source packages ship an affected version, including @jhb.software/payload-alt-text-plugin.

PackageAffectedFixed in
@jhb.software/payload-alt-text-plugin npmAll versions0.8.0
@jhb.software/payload-alt-text-plugin npmAll versions0.8.0

How do I fix CVE-2026-59965?

Upgrade @jhb.software/payload-alt-text-plugin to 0.8.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-59965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59965 exists.

Sources

Also known as GHSA-4qpv-39hg-f7fx.

Is CVE-2026-59965 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free