# CVE-2026-59965: @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission

> An authenticated low-privilege user can bypass access controls to read and modify protected upload documents in Payload CMS via the alt-text plugin.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-4qpv-39hg-f7fx

## What is CVE-2026-59965?

CVE-2026-59965 is a high-severity missing authorization vulnerability in @jhb.software payload-alt-text-plugin, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-59965?

2 open source packages ship an affected version, including @jhb.software/payload-alt-text-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@jhb.software/payload-alt-text-plugin` | npm | All versions | 0.8.0 |
| `@jhb.software/payload-alt-text-plugin` | npm | All versions | 0.8.0 |

## How do I fix CVE-2026-59965?

Upgrade @jhb.software/payload-alt-text-plugin to 0.8.0 or later.

## Is CVE-2026-59965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59965 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59965 and fix it if it is affected.

What it is: CVE-2026-59965 is a high-severity missing authorization vulnerability in @jhb.software payload-alt-text-plugin, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59965 exists.

Affected packages and fixed versions:
- @jhb.software/payload-alt-text-plugin (npm): affected all versions; fixed in 0.8.0
- @jhb.software/payload-alt-text-plugin (npm): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59965/ (Markdown: https://insights.sbomify.com/CVE-2026-59965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59965
- OSV: https://osv.dev/vulnerability/CVE-2026-59965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59965/
Summaries are generated and may contain mistakes; the official description above is the record.
