CVE-2026-59973 mcp-from-openapi: Bypass of OpenAPI external $ref SSRF fix in latest FrontMCP and mcp-from-openapi
Authenticated users can bypass SSRF protections in FrontMCP to access internal network services via malicious OpenAPI specifications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59973?
CVE-2026-59973 is a high-severity server-side request forgery vulnerability in @frontmcp adapters, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). From mcp-from-openapi 2.3.0 until 2.5.0 and from frontmcp and @frontmcp/adapters 1.2.1 until 1.5.0, libs/adapters/src/openapi/openapi.adapter.ts loadOpenAPISpec() forwards untrusted OpenAPI url and spec inputs and loadOptions.refResolution to OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON(). The external $ref guard checks parsed hostname strings without resolving addresses, pinning validated addresses, revalidating redirect targets, or normalizing IPv4-mapped IPv6. An authenticated user who can import or configure an OpenAPI specification in a hosted or multi-user deployment can use DNS-to-loopback resolution, redirect-to-loopback behavior, or IPv4-mapped IPv6 loopback forms to cause backend-origin requests to internal services. This can expose internal administrative APIs, metadata-like services, and other private network endpoints. The practical impact is lower when only a trusted local administrator can configure OpenAPI specs, and disabling external reference protocols prevents the external $ref request. This issue is fixed in mcp-from-openapi 2.5.0 and frontmcp and @frontmcp/adapters 1.5.0.
Weakness: CWE-918
Which versions are affected by CVE-2026-59973?
6 open source packages ship an affected version, including @frontmcp/adapters, frontmcp and mcp-from-openapi.
| Package | Affected | Fixed in |
|---|---|---|
@frontmcp/adapters npm | From 1.2.1 | 1.5.0 |
@frontmcp/adapters npm | From 1.2.1 | 1.5.0 |
frontmcp npm | From 1.2.1 | 1.5.0 |
frontmcp npm | From 1.2.1 | 1.5.0 |
mcp-from-openapi npm | From 2.3.0 | 2.5.0 |
mcp-from-openapi npm | From 2.3.0 | 2.5.0 |
How do I fix CVE-2026-59973?
Upgrade @frontmcp/adapters to 1.5.0 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-59973 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59973 exists.
Sources
Also known as GHSA-65h7-9wrw-629c.