# CVE-2026-59973: mcp-from-openapi: Bypass of OpenAPI external $ref SSRF fix in latest FrontMCP and mcp-from-openapi

> Authenticated users can bypass SSRF protections in FrontMCP to access internal network services via malicious OpenAPI specifications.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-65h7-9wrw-629c

## What is CVE-2026-59973?

CVE-2026-59973 is a high-severity server-side request forgery vulnerability in @frontmcp adapters, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). From mcp-from-openapi 2.3.0 until 2.5.0 and from frontmcp and @frontmcp/adapters 1.2.1 until 1.5.0, libs/adapters/src/openapi/openapi.adapter.ts loadOpenAPISpec() forwards untrusted OpenAPI url and spec inputs and loadOptions.refResolution to OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON(). The external $ref guard checks parsed hostname strings without resolving addresses, pinning validated addresses, revalidating redirect targets, or normalizing IPv4-mapped IPv6. An authenticated user who can import or configure an OpenAPI specification in a hosted or multi-user deployment can use DNS-to-loopback resolution, redirect-to-loopback behavior, or IPv4-mapped IPv6 loopback forms to cause backend-origin requests to internal services. This can expose internal administrative APIs, metadata-like services, and other private network endpoints. The practical impact is lower when only a trusted local administrator can configure OpenAPI specs, and disabling external reference protocols prevents the external $ref request. This issue is fixed in mcp-from-openapi 2.5.0 and frontmcp and @frontmcp/adapters 1.5.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-59973?

6 open source packages ship an affected version, including @frontmcp/adapters, frontmcp and mcp-from-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@frontmcp/adapters` | npm | From 1.2.1 | 1.5.0 |
| `@frontmcp/adapters` | npm | From 1.2.1 | 1.5.0 |
| `frontmcp` | npm | From 1.2.1 | 1.5.0 |
| `frontmcp` | npm | From 1.2.1 | 1.5.0 |
| `mcp-from-openapi` | npm | From 2.3.0 | 2.5.0 |
| `mcp-from-openapi` | npm | From 2.3.0 | 2.5.0 |

## How do I fix CVE-2026-59973?

Upgrade @frontmcp/adapters to 1.5.0 or later.

## Is CVE-2026-59973 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59973 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59973 and fix it if it is affected.

What it is: CVE-2026-59973 is a high-severity server-side request forgery vulnerability in @frontmcp adapters, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59973 exists.

Affected packages and fixed versions:
- @frontmcp/adapters (npm): affected from 1.2.1; fixed in 1.5.0
- @frontmcp/adapters (npm): affected from 1.2.1; fixed in 1.5.0
- frontmcp (npm): affected from 1.2.1; fixed in 1.5.0
- frontmcp (npm): affected from 1.2.1; fixed in 1.5.0
- mcp-from-openapi (npm): affected from 2.3.0; fixed in 2.5.0
- mcp-from-openapi (npm): affected from 2.3.0; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59973/ (Markdown: https://insights.sbomify.com/CVE-2026-59973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59973
- OSV: https://osv.dev/vulnerability/CVE-2026-59973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59973/
Summaries are generated and may contain mistakes; the official description above is the record.
