# CVE-2026-59980: hpack: Unbounded variable integer decoding can cause run-away computation on malformed input


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** CLEANSTART-2026-WU74095, CLEANSTART-2026-YJ27178, DEBIAN-CVE-2026-59980, ECHO-b10e-5b40-f5bb, GHSA-8v8h-hg4w-mvq2, MGASA-2026-0349, MINI-33cj-rpv8-jp3g, MINI-q34p-fr92-r6wf, OESA-2026-4239, OESA-2026-4240, OESA-2026-4241, OESA-2026-4242, PYSEC-2026-4053, SUSE-SU-2026:24216-1, SUSE-SU-2026:4593-1, SUSE-SU-2026:4832-1, UBUNTU-CVE-2026-59980, openSUSE-SU-2026:22070-1

## What is CVE-2026-59980?

CVE-2026-59980 is a medium-severity vulnerability in python-hyper hpack, published on 23 Sep 2026. 

### Official description

hpack is an HTTP/2 Header Encoding for Python. Prior to version 4.2.0, unbounded variable integer decoding can cause run-away computation on malformed input leading to O(n^2) runtime, effectively blocking further processing with large enough unsanitized input. A fix is available in python-hyper/hpack v4.2.0 to restricted variable integer decoding to uint32 to prevent run-away computation. As a workaround, sanitize input to hpack decoder for long sequences of `0xFF` values to prevent malicious use.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59980?

3 open source packages ship an affected version, including hpack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hpack` | PyPI | All versions | 4.2.0 |
| `hpack` | PyPI | All versions | 4.2.0 |
| `hpack` | PyPI | All versions | 4.2.0 |
| `python-hpack` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 4.0.0-150400.8.6.1 |
| `python-hpack` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.0.0-150200.3.5.1 |
| `python-hpack` | SUSE:Linux Enterprise Server 16.0 | All versions | 4.1.0-160000.3.1 |
| `python-hpack` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 4.1.0-160000.3.1 |
| `python-hpack` | openSUSE:Leap 16.0 | All versions | 4.1.0-160000.3.1 |

## How do I fix CVE-2026-59980?

Upgrade hpack to 4.2.0 or later.

## Is CVE-2026-59980 being exploited?

There is no known exploitation of CVE-2026-59980 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59980 and fix it if it is affected.

What it is: CVE-2026-59980 is a medium-severity vulnerability in python-hyper hpack, published on 23 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-59980 in the wild and no public exploit code.

Affected packages and fixed versions:
- hpack (PyPI): affected all versions; fixed in 4.2.0
- hpack (PyPI): affected all versions; fixed in 4.2.0
- hpack (PyPI): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59980/ (Markdown: https://insights.sbomify.com/CVE-2026-59980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59980
- OSV: https://osv.dev/vulnerability/CVE-2026-59980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59980/
Summaries are generated and may contain mistakes; the official description above is the record.
