# CVE-2026-59984: OpenEXR: Scratch buffer overflow decoding B44-compressed InputFile on ILP32

> A crafted B44-compressed EXR file can cause an out-of-bounds write in OpenEXR on ILP32 systems, leading to memory corruption and potential code execution.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BELL-CVE-2026-59984, DEBIAN-CVE-2026-59984, ECHO-818f-3ecd-dadb, GHSA-92pq-9qv4-g68q, MINI-8x46-xxgj-fhp4, UBUNTU-CVE-2026-59984

## What is CVE-2026-59984?

CVE-2026-59984 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. OpenEXR versions 3.1.0 through 3.2.10, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 are vulnerable on ILP32 builds to an out-of-bounds write. When a crafted B44-compressed scanline EXR causes the logical scratch size to truncate before allocation and uncompress_b44_impl() writes using the attacker-controlled channel width, allowing denial of service and memory corruption. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-59984?


## How do I fix CVE-2026-59984?

Upgrade to a fixed version.

## Is CVE-2026-59984 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59984 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59984 and fix it if it is affected.

What it is: CVE-2026-59984 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59984 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59984/ (Markdown: https://insights.sbomify.com/CVE-2026-59984/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59984
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59984
- OSV: https://osv.dev/vulnerability/CVE-2026-59984

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59984/
Summaries are generated and may contain mistakes; the official description above is the record.
