# CVE-2026-59989: Phalcon Volt compiler `join` filter compile-time PHP code injection (SSTI lead to RCE)

> Attackers can inject PHP code via Volt template join filters, leading to remote code execution when templates are rendered.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-hrwp-4hh9-c8r8

## What is CVE-2026-59989?

CVE-2026-59989 is a critical code injection vulnerability in cphalcon, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Phalcon is a high-performance, full-stack PHP framework. In 5.15.0 and earlier, resolveFilter in phalcon/Mvc/View/Engine/Volt/Compiler.zep builds the join filter by inserting the raw separator and array token values into generated PHP without passing them through expression(). An attacker who can influence Volt template source can place quote-breaking content in a join argument, inject PHP into the compiled cache file, and execute it when Phalcon\Mvc\View\Engine\Volt::render() loads the template. This issue is fixed in version 5.16.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-59989?

2 open source packages ship an affected version, including phalcon/cphalcon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phalcon/cphalcon` | Packagist | All versions | 5.16.0 |
| `phalcon/cphalcon` | Packagist | All versions | 5.16.0 |

## How do I fix CVE-2026-59989?

Upgrade phalcon/cphalcon to 5.16.0 or later.

## Is CVE-2026-59989 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59989 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59989 and fix it if it is affected.

What it is: CVE-2026-59989 is a critical code injection vulnerability in cphalcon, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59989 exists.

Affected packages and fixed versions:
- phalcon/cphalcon (Packagist): affected all versions; fixed in 5.16.0
- phalcon/cphalcon (Packagist): affected all versions; fixed in 5.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59989/ (Markdown: https://insights.sbomify.com/CVE-2026-59989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59989
- OSV: https://osv.dev/vulnerability/CVE-2026-59989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59989/
Summaries are generated and may contain mistakes; the official description above is the record.
