CVE-2026-59990 Jawn: Uncontrolled nesting depth in JSON parser
Remote attackers can cause denial of service in applications using Jawn by submitting deeply nested JSON, exhausting JVM memory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59990?
CVE-2026-59990 is a high-severity denial of service vulnerability in typelevel jawn, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jawn is an open source JSON parser. Prior to 1.7.0, Jawn parse methods accept arbitrarily deep JSON array and object nesting without a depth limit, allowing a remote attacker who can submit untrusted JSON to grow parser contexts until the JVM heap is exhausted. The resulting java.lang.OutOfMemoryError is a fatal Scala error that is not ordinarily handled by scala.util.Try or cats.effect.IO, causing denial of service. This issue is fixed in version 1.7.0.
Weakness: CWE-770
Which versions are affected by CVE-2026-59990?
6 open source packages ship an affected version, including org.typelevel:jawn-parser_2.12, org.typelevel:jawn-parser_2.13 and org.typelevel:jawn-parser_3.
| Package | Affected | Fixed in |
|---|---|---|
org.typelevel:jawn-parser_2.12 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.12 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.13 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.13 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_3 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_3 Maven | All versions | 1.7.0 |
How do I fix CVE-2026-59990?
Upgrade org.typelevel:jawn-parser_2.12 to 1.7.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-59990 being exploited?
There is no known exploitation of CVE-2026-59990 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-59990, GHSA-cc4v-rvgp-2pf3, UBUNTU-CVE-2026-59990.