{"answers":{"affected":"3 open source packages ship an affected version, including psd-tools.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59991 exists.","fix":"Upgrade psd-tools to 1.17.4 or later.","what":"CVE-2026-59991 is a high-severity denial of service vulnerability in psd-tools, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59991 and fix it if it is affected.\n\nWhat it is: CVE-2026-59991 is a high-severity denial of service vulnerability in psd-tools, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59991 exists.\n\nAffected packages and fixed versions:\n- psd-tools (PyPI): affected all versions; fixed in 1.17.4\n- psd-tools (PyPI): affected all versions; fixed in 1.17.4\n- psd-tools (PyPI): affected all versions; fixed in 1.17.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59991/ (Markdown: https://insights.sbomify.com/CVE-2026-59991/index.md)","id":"CVE-2026-59991","markdown":"https://insights.sbomify.com/CVE-2026-59991/index.md","name":"CVE-2026-59991","record":{"aliases":["DEBIAN-CVE-2026-59991","GHSA-8q6g-vjhf-jp8m","PYSEC-2026-4139","UBUNTU-CVE-2026-59991"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python PSD library","requires_auth":"none","summary":"Attackers can cause out-of-memory crashes in applications using psd-tools by providing crafted PSD files with invalid geometry.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to 1.17.4, PSDImage.composite() and PSDImage.numpy() allocated output buffers from attacker-controlled PSD header geometry, including width, height, channels, depth, and per-layer rectangles, before validating those values against the available file data. A tiny crafted PSD could therefore cause multi-gigabyte memory allocation, and PSDImage.composite() could return a black image with only a warning instead of raising an exception. Services that composite untrusted PSD files could be terminated by out-of-memory handling. This issue is fixed in version 1.17.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"psd-tools: Uncontrolled memory allocation in psd-tools composite/numpy via crafted PSD geometry","id":"CVE-2026-59991","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Tina: Broken Access Control: arbitrary bucket-key write/delete in `next-tinacms-s3` (and sibling production media adapters)","id":"CVE-2026-59992"},"packages":[{"ecosystem":"PyPI","fixed":["1.17.4"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":null,"source":"GHSA-8q6g-vjhf-jp8m"},{"ecosystem":"PyPI","fixed":["1.17.4"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":"pkg:pypi/psd-tools","source":"GHSA-8q6g-vjhf-jp8m"},{"ecosystem":"PyPI","fixed":["1.17.4"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":"pkg:pypi/psd-tools","source":"PYSEC-2026-4139"}],"prev":{"headline":"Jawn: Uncontrolled nesting depth in JSON parser","id":"CVE-2026-59990"},"products":["psd-tools"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["psd-tools"]},"summary":"Attackers can cause out-of-memory crashes in applications using psd-tools by providing crafted PSD files with invalid geometry.","url":"https://insights.sbomify.com/CVE-2026-59991/"}