# CVE-2026-59991: psd-tools: Uncontrolled memory allocation in psd-tools composite/numpy via crafted PSD geometry

> Attackers can cause out-of-memory crashes in applications using psd-tools by providing crafted PSD files with invalid geometry.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-59991, GHSA-8q6g-vjhf-jp8m, PYSEC-2026-4139, UBUNTU-CVE-2026-59991

## What is CVE-2026-59991?

CVE-2026-59991 is a high-severity denial of service vulnerability in psd-tools, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to 1.17.4, PSDImage.composite() and PSDImage.numpy() allocated output buffers from attacker-controlled PSD header geometry, including width, height, channels, depth, and per-layer rectangles, before validating those values against the available file data. A tiny crafted PSD could therefore cause multi-gigabyte memory allocation, and PSDImage.composite() could return a black image with only a warning instead of raising an exception. Services that composite untrusted PSD files could be terminated by out-of-memory handling. This issue is fixed in version 1.17.4.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-59991?

3 open source packages ship an affected version, including psd-tools.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `psd-tools` | PyPI | All versions | 1.17.4 |
| `psd-tools` | PyPI | All versions | 1.17.4 |
| `psd-tools` | PyPI | All versions | 1.17.4 |

## How do I fix CVE-2026-59991?

Upgrade psd-tools to 1.17.4 or later.

## Is CVE-2026-59991 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59991 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59991 and fix it if it is affected.

What it is: CVE-2026-59991 is a high-severity denial of service vulnerability in psd-tools, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59991 exists.

Affected packages and fixed versions:
- psd-tools (PyPI): affected all versions; fixed in 1.17.4
- psd-tools (PyPI): affected all versions; fixed in 1.17.4
- psd-tools (PyPI): affected all versions; fixed in 1.17.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59991/ (Markdown: https://insights.sbomify.com/CVE-2026-59991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59991
- OSV: https://osv.dev/vulnerability/CVE-2026-59991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59991/
Summaries are generated and may contain mistakes; the official description above is the record.
