# CVE-2026-59994: EspoCRM: Pre-authentication stored HTML injection in stream notification emails about email received

> Unauthenticated attackers can inject HTML/JavaScript into EspoCRM notification emails via crafted incoming emails, potentially leading to code execution or account takeover.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-3rh4-9hcq-g79m

## What is CVE-2026-59994?

CVE-2026-59994 is a medium-severity cross-site scripting vulnerability in espocrm, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

EspoCRM is an open source customer relationship management application. Prior to 9.3.9, an unauthenticated remote attacker can send an email to a monitored group or IMAP address, including an email-to-Case address, and place arbitrary HTML in its plain-text body. EspoCRM stores that body and renders it without escaping in Email Received stream notification emails sent to users following the related record, allowing HTML injection and, in mail clients that execute it, JavaScript execution. Earlier sanitization for Post and Mention notifications did not cover this notification path. This issue is fixed in version 9.3.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-59994?


## How do I fix CVE-2026-59994?

No fix has been published for CVE-2026-59994 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59994 being exploited?

There is no known exploitation of CVE-2026-59994 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59994 and fix it if it is affected.

What it is: CVE-2026-59994 is a medium-severity cross-site scripting vulnerability in espocrm, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59994 in the wild and no public exploit code.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59994/ (Markdown: https://insights.sbomify.com/CVE-2026-59994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59994
- OSV: https://osv.dev/vulnerability/CVE-2026-59994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59994/
Summaries are generated and may contain mistakes; the official description above is the record.
