{"answers":{"affected":"1 open source package ship an affected version, including nginx-agent. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-60062 in the wild and no public exploit code.","fix":"Upgrade nginx-agent to 2.47.0 or later.","what":"CVE-2026-60062 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-60062 and fix it if it is affected.\n\nWhat it is: CVE-2026-60062 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-60062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-agent (Bitnami): affected from 2.37.0; fixed in 2.47.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-60062/ (Markdown: https://insights.sbomify.com/CVE-2026-60062/index.md)","id":"CVE-2026-60062","markdown":"https://insights.sbomify.com/CVE-2026-60062/index.md","name":"CVE-2026-60062","record":{"aliases":["BIT-nginx-agent-2026-60062","GHSA-66rh-w67w-7426"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"NGINX Agent","requires_auth":"low_privilege","summary":"A low-privileged attacker can read and write files outside secure directories via the config_dirs directive in NGINX Agent.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_agent","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The NGINX Agent config_dirs directive allows a low-privileged attacker to gain limited read and write access to files outside of the designated secure directory. The config_dirs directive required for this issue can also be configured through NGINX Instance Manager. A successful exploit may allow an attacker to cross a security boundary.\n\nImpact:\nA remotely authenticated low-privileged attacker could gain limited read and write access outside of the list of directories specified in the NGINX Agent configuration.\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Agent Vulnerability","id":"CVE-2026-60062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"AutomationDirect Productivity Suite Out-of-bounds Write","id":"CVE-2026-60063"},"packages":[{"ecosystem":"Bitnami","fixed":["2.47.0"],"introduced":["2.37.0"],"last_affected":[],"package":"nginx-agent","purl":"pkg:bitnami/nginx-agent","source":"BIT-nginx-agent-2026-60062"}],"prev":{"headline":"Memory corruption in TTSSH2","id":"CVE-2026-60060"},"products":["NGINX Agent","NGINX Instance Manager"],"published":"2026-07-15","related":[{"cvss_score":6.9,"headline":"NGINX Agent Vulnerability","id":"CVE-2024-7634","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":5.5,"headline":"NGINX Agent vulnerability CVE-2023-1550","id":"CVE-2023-1550","kev_date_added":null,"published":"2023-03-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["F5"]},"summary":"A low-privileged attacker can read and write files outside secure directories via the config_dirs directive in NGINX Agent.","url":"https://insights.sbomify.com/CVE-2026-60062/"}