# CVE-2026-60062: NGINX Agent Vulnerability

> A low-privileged attacker can read and write files outside secure directories via the config_dirs directive in NGINX Agent.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-nginx-agent-2026-60062, GHSA-66rh-w67w-7426

## What is CVE-2026-60062?

CVE-2026-60062 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The NGINX Agent config_dirs directive allows a low-privileged attacker to gain limited read and write access to files outside of the designated secure directory. The config_dirs directive required for this issue can also be configured through NGINX Instance Manager. A successful exploit may allow an attacker to cross a security boundary.

Impact:
A remotely authenticated low-privileged attacker could gain limited read and write access outside of the list of directories specified in the NGINX Agent configuration.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-60062?

1 open source package ship an affected version, including nginx-agent. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-agent` | Bitnami | From 2.37.0 | 2.47.0 |

Products: F5 Nginx Agent, F5 Nginx Instance Manager.

## How do I fix CVE-2026-60062?

Upgrade nginx-agent to 2.47.0 or later.

## Is CVE-2026-60062 being exploited?

There is no known exploitation of CVE-2026-60062 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Agent

- [CVE-2024-7634](https://insights.sbomify.com/CVE-2024-7634/): NGINX Agent Vulnerability (medium 6.9)
- [CVE-2023-1550](https://insights.sbomify.com/CVE-2023-1550/): NGINX Agent vulnerability CVE-2023-1550 (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60062 and fix it if it is affected.

What it is: CVE-2026-60062 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-60062 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-agent (Bitnami): affected from 2.37.0; fixed in 2.47.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60062/ (Markdown: https://insights.sbomify.com/CVE-2026-60062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60062
- OSV: https://osv.dev/vulnerability/CVE-2026-60062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60062/
Summaries are generated and may contain mistakes; the official description above is the record.
