CVE-2026-60080 Apache Fory: Rust MetaString heap use-after-free

High 7.3 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-60080?

CVE-2026-60080 is a high-severity vulnerability in Apache Fory, published on 21 Jul 2026.

Official description

Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0.

A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure.

Users are recommended to upgrade to version 1.4.0, which fixes the issue.

Weakness: CWE-416

Which versions are affected by CVE-2026-60080?

It affects 1 product.

Products include Apache Fory.

How do I fix CVE-2026-60080?

No fix has been published for CVE-2026-60080 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-60080 being exploited?

There is no known exploitation of CVE-2026-60080 in the wild and no public exploit code.

Sources

Also known as GHSA-8g3p-5q43-955w.

Is CVE-2026-60080 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free