# CVE-2026-60085: PraisonAI before 4.6.78 Unenforced Security Policy in Subprocess Sandbox

> Attackers can bypass subprocess sandbox restrictions in PraisonAI to execute arbitrary commands and access sensitive files.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62177, GHSA-5r6c-gj4g-r697, PYSEC-2026-4250

## What is CVE-2026-60085?

CVE-2026-60085 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 4.6.78 contains an unenforced security policy vulnerability in the default Subprocess Sandbox backend where blocked_commands, blocked_paths, blocked_imports, allow_subprocess, and allow_file_write restrictions are completely ignored. Attackers can execute arbitrary subprocess commands, read sensitive files, and perform destructive operations despite explicit security policy configuration.

Weakness: CWE-273 (Improper Check for Dropped Privileges)

## Which versions are affected by CVE-2026-60085?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-60085?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-60085 being exploited?

There is no known exploitation of CVE-2026-60085 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60085 and fix it if it is affected.

What it is: CVE-2026-60085 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-60085 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60085/ (Markdown: https://insights.sbomify.com/CVE-2026-60085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60085
- OSV: https://osv.dev/vulnerability/CVE-2026-60085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60085/
Summaries are generated and may contain mistakes; the official description above is the record.
