{"answers":{"affected":"3 open source packages ship an affected version, including praisonai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60086 exists.","fix":"Upgrade praisonai to 4.6.78 or later.","what":"CVE-2026-60086 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-60086 and fix it if it is affected.\n\nWhat it is: CVE-2026-60086 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60086 exists.\n\nAffected packages and fixed versions:\n- praisonai (PyPI): affected all versions; fixed in 4.6.78\n- praisonai (PyPI): affected all versions; fixed in 4.6.78\n- praisonai (PyPI): affected all versions; fixed in 4.6.78\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-60086/ (Markdown: https://insights.sbomify.com/CVE-2026-60086/index.md)","id":"CVE-2026-60086","markdown":"https://insights.sbomify.com/CVE-2026-60086/index.md","name":"CVE-2026-60086","record":{"aliases":["GHSA-4r3p-w3mc-5v34","PYSEC-2026-4248"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI library","requires_auth":"none","summary":"Attackers can bypass prompt injection defenses in PraisonAI by crafting attacks that evade strict multi-detector blocking thresholds.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"PraisonAI before 4.6.78 contains a prompt injection defense bypass vulnerability where the injection defense only blocks threats classified as CRITICAL, requiring three or more detector families to match simultaneously. Attackers can craft single or double-vector prompt injections that are classified as HIGH threat level and pass through unblocked to reach the model.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PraisonAI before 4.6.78 Prompt Injection Defense Bypass","id":"CVE-2026-60086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"PraisonAI before 1.6.78 Tool Approval Cache Bypass","id":"CVE-2026-60087"},"packages":[{"ecosystem":"PyPI","fixed":["4.6.78"],"introduced":["0"],"last_affected":[],"package":"praisonai","purl":null,"source":"GHSA-4r3p-w3mc-5v34"},{"ecosystem":"PyPI","fixed":["4.6.78"],"introduced":["0"],"last_affected":[],"package":"praisonai","purl":"pkg:pypi/praisonai","source":"GHSA-4r3p-w3mc-5v34"},{"ecosystem":"PyPI","fixed":["4.6.78"],"introduced":["0"],"last_affected":[],"package":"praisonai","purl":"pkg:pypi/praisonai","source":"PYSEC-2026-4248"}],"prev":{"headline":"PraisonAI before 4.6.78 Unenforced Security Policy in Subprocess Sandbox","id":"CVE-2026-60085"},"products":["PraisonAI"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["MervinPraison"]},"summary":"Attackers can bypass prompt injection defenses in PraisonAI by crafting attacks that evade strict multi-detector blocking thresholds.","url":"https://insights.sbomify.com/CVE-2026-60086/"}