# CVE-2026-60087: PraisonAI before 1.6.78 Tool Approval Cache Bypass

> Attackers bypass tool approval checks in PraisonAI by reusing cached decisions, enabling unauthorized execution of dangerous file write operations.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62164, GHSA-29r9-67vg-qj56, PYSEC-2026-4265

## What is CVE-2026-60087?

CVE-2026-60087 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 1.6.78 caches tool approval decisions by tool name only, allowing attackers to reuse initial approvals for subsequent calls with arbitrary arguments. Attackers can exploit this by obtaining approval for a benign operation and then executing dangerous file write operations with unreviewed parameters in the same session.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-60087?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |

## How do I fix CVE-2026-60087?

Upgrade praisonaiagents to 1.6.78 or later.

## Is CVE-2026-60087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60087 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60087 and fix it if it is affected.

What it is: CVE-2026-60087 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60087 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60087/ (Markdown: https://insights.sbomify.com/CVE-2026-60087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60087
- OSV: https://osv.dev/vulnerability/CVE-2026-60087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60087/
Summaries are generated and may contain mistakes; the official description above is the record.
