# CVE-2026-60088: PraisonAI before 4.6.78 Path Traversal via Custom Commands

> Attackers can read arbitrary files outside the workspace by injecting path traversal sequences into custom command templates in PraisonAI.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-xpx6-x8c2-mw5w, PYSEC-2026-4261

## What is CVE-2026-60088?

CVE-2026-60088 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 4.6.78 fails to validate file path references in custom command templates, allowing attackers to read files outside the workspace. Attackers can include path traversal sequences like @../outside_secret.txt or absolute paths in project command files to exfiltrate process-readable files into model prompts.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-60088?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-60088?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-60088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60088 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60088 and fix it if it is affected.

What it is: CVE-2026-60088 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60088 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60088/ (Markdown: https://insights.sbomify.com/CVE-2026-60088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60088
- OSV: https://osv.dev/vulnerability/CVE-2026-60088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60088/
Summaries are generated and may contain mistakes; the official description above is the record.
