# CVE-2026-60089: PraisonAI before 1.6.78 Path Traversal via config.toml

> Attackers can overwrite arbitrary files via malicious config in untrusted projects, impacting developers using PraisonAI.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** CVE-2026-62163, GHSA-qjw5-xwrp-xwpq, PYSEC-2026-4273

## What is CVE-2026-60089?

CVE-2026-60089 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI (pip package praisonaiagents) before 1.6.78 automatically loads defaults from a project-local .praisonai/config.toml when constructing an Agent, and does not validate the defaults.output.output_file path. A repository-controlled config file can set output_file to an absolute or '..' traversal path; when the developer subsequently calls agent.start() without explicitly passing an output parameter, PraisonAI writes the agent response to that path (creating parent directories as needed), allowing an untrusted checked-out project to overwrite files outside the project root with the privileges of the user running PraisonAI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-60089?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |

## How do I fix CVE-2026-60089?

Upgrade praisonaiagents to 1.6.78 or later.

## Is CVE-2026-60089 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60089 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60089 and fix it if it is affected.

What it is: CVE-2026-60089 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60089 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60089/ (Markdown: https://insights.sbomify.com/CVE-2026-60089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60089
- OSV: https://osv.dev/vulnerability/CVE-2026-60089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60089/
Summaries are generated and may contain mistakes; the official description above is the record.
