# CVE-2026-60090: PraisonAI before 4.6.78 SQL/CQL Injection via vector dimension

> Attackers can inject SQL or CQL commands via the dimension argument in PraisonAI's knowledge-store creation, potentially modifying or reading database contents.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-wf65-4jjx-q444, PYSEC-2026-4260

## What is CVE-2026-60090?

CVE-2026-60090 is a critical SQL injection vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 4.6.78 fails to validate the caller-controlled dimension argument in the PGVector and Cassandra knowledge-store create_collection() backends. Although schema, keyspace, and collection-name identifiers are validated, the dimension value (declared as int but not enforced at runtime) is interpolated directly into the vector column of the generated CREATE TABLE DDL. A caller able to influence collection-creation dimensions can pass a string such as '3); DROP TABLE tenant_secrets; --' to inject SQL/CQL tokens into the statement executed by the database driver.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-60090?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-60090?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-60090 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60090 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60090 and fix it if it is affected.

What it is: CVE-2026-60090 is a critical SQL injection vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60090 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60090/ (Markdown: https://insights.sbomify.com/CVE-2026-60090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60090
- OSV: https://osv.dev/vulnerability/CVE-2026-60090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60090/
Summaries are generated and may contain mistakes; the official description above is the record.
