# CVE-2026-60091: PraisonAI before 4.6.78 Unauthenticated SSRF via webhook_url

> Unauthenticated attackers can perform blind SSRF via DNS rebinding in the Jobs API, potentially accessing internal services.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** CVE-2026-62175, GHSA-4w49-gwv8-fpjg, PYSEC-2026-4249

## What is CVE-2026-60091?

CVE-2026-60091 is a medium-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 4.6.78 contains an unauthenticated server-side request forgery vulnerability in the Jobs API /api/v1/runs endpoint. The webhook_url parameter is validated at request time but re-resolved at connection time, allowing attackers to use DNS rebinding to reach internal services with a blind SSRF attack.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-60091?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-60091?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-60091 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60091 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60091 and fix it if it is affected.

What it is: CVE-2026-60091 is a medium-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-60091 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60091/ (Markdown: https://insights.sbomify.com/CVE-2026-60091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60091
- OSV: https://osv.dev/vulnerability/CVE-2026-60091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60091/
Summaries are generated and may contain mistakes; the official description above is the record.
