# CVE-2026-60137: WordPress Core SQL Injection

> Attackers can execute SQL injection via the author__not_in parameter in WP_Query if plugins or themes pass untrusted input, requiring an upgrade to WordPress.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 21 Jul 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-wordpress-2026-60137, BIT-wordpress-multisite-2026-60137, DEBIAN-CVE-2026-60137, MINI-cvxg-6j2r-774h, MINI-gp5r-m5x6-3h6g, UBUNTU-CVE-2026-60137

## What is CVE-2026-60137?

CVE-2026-60137 is a medium-severity SQL injection vulnerability in Wordpress Wordpress, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-60137?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 6.8.0 | 6.8.6, 6.9.5, 7.0.2 |
| `wordpress-multisite` | Bitnami | From 6.8.0 | 6.8.6, 6.9.5, 7.0.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2026-60137?

Upgrade wordpress to a fixed version for your release line: 6.8.6, 6.9.5 or 7.0.2. US federal agencies must fix it by 4 Aug 2026.

## Is CVE-2026-60137 being exploited?

Yes. Attackers have exploited CVE-2026-60137 in the wild since at least 21 Jul 2026.

Public exploit code:

- wp2shell — Pre-authentication RCE in WordPress Core (CVE-2026-60137 + CVE-2026-63030). Chains an SQL injection in author__not_in with batch-route confusion for unauthenticated remote code execution on WP 6.9.0–6.9.4 / 7.0.0–7.0.1. (github_poc): https://github.com/codeb0ssx/Ultimate-wp2shell
- Analysis and end-to-end implementation of the patched wordpress RCE vulnerability - CVE-2026-60137 and CVE-2026-63030 (github_poc): https://github.com/Colere-Sys/wp2shell-poc
- WordPress Core wp2shell Unauthenticated SQL Injection via REST Batch Route Confusion (metasploit)
- WordPress WP2Shell REST API Batch Route Confusion SQLi to RCE (metasploit)
- wp2shell — Pre-authentication RCE in WordPress Core (CVE-2026-60137 + CVE-2026-63030). Chains an SQL injection in author__not_in with batch-route confusion for unauthenticated remote code execution on WP 6.9.0–6.9.4 / 7.0.0–7.0.1. (github_poc): https://github.com/h4cd0c/wp2shell
- CVE-2026-60137Temporary Emergency Mitigation for CVE-2026-60137 & CVE-2026-63030 (wp2shell) (github_poc): https://github.com/mrmtwoj/Fix-CVE-2026-60137-CVE-2026-63030-in-wordpress

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)
- [CVE-2011-3122](https://insights.sbomify.com/CVE-2011-3122/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60137 and fix it if it is affected.

What it is: CVE-2026-60137 is a medium-severity SQL injection vulnerability in Wordpress Wordpress, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-60137 in the wild since at least 21 Jul 2026.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 6.8.0; fixed in 6.8.6, 6.9.5, 7.0.2
- wordpress-multisite (Bitnami): affected from 6.8.0; fixed in 6.8.6, 6.9.5, 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60137/ (Markdown: https://insights.sbomify.com/CVE-2026-60137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60137
- OSV: https://osv.dev/vulnerability/CVE-2026-60137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60137/
Summaries are generated and may contain mistakes; the official description above is the record.
