CVE-2026-60589 Information disclosure in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition
An unauthenticated attacker can read a subset of accessible data in Oracle Java SE and GraalVM via network access, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-60589?
CVE-2026-60589 is a low-severity vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Security). Supported versions that are affected are Oracle Java SE: 8u501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2; Oracle GraalVM for JDK: 17.0.20 and 21.0.12; Oracle GraalVM Enterprise Edition: 21.3.19. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).
Weakness: CWE-200
Which versions are affected by CVE-2026-60589?
3 open source packages ship an affected version, including java, java-min and jre.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
java-min Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
jre Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
How do I fix CVE-2026-60589?
Upgrade java to a fixed version for your release line: 1.8.0, 8.0.503, 11.0.32-1 or 17.0.20-1.
Is CVE-2026-60589 being exploited?
There is no known exploitation of CVE-2026-60589 in the wild and no public exploit code.
Sources
Also known as BELL-CVE-2026-60589, BIT-java-2026-60589, BIT-java-min-2026-60589, BIT-jre-2026-60589, DEBIAN-CVE-2026-60589, GHSA-47g6-3p6h-6cpc and 29 more.