# CVE-2026-60589: Information disclosure in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition

> An unauthenticated attacker can read a subset of accessible data in Oracle Java SE and GraalVM via network access, requiring an upgrade to mitigate.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** BELL-CVE-2026-60589, BIT-java-2026-60589, BIT-java-min-2026-60589, BIT-jre-2026-60589, DEBIAN-CVE-2026-60589, GHSA-47g6-3p6h-6cpc, MINI-2977-j2mm-xvrv, MINI-45g8-9749-p7pj, MINI-5257-736j-mqr5, MINI-52w5-9c66-cv2q, MINI-5556-6w43-rm75, MINI-8m36-xhj3-48m7, MINI-95q5-9q24-7g8q, MINI-95qm-hqj4-gp98, MINI-c858-q464-qjrp, MINI-f9p5-5qxw-jjwh, MINI-fc8r-9vw5-m5pp, MINI-fr73-5fvm-j94r, MINI-frf7-cjv3-mrhj, MINI-fw2w-qhmp-hgfw, MINI-hjr4-9r8p-99cr, MINI-j66w-63gg-gp35, MINI-j8hq-25xw-84g3, MINI-j8q4-wvhm-3rgg, MINI-mch7-hqrg-7g64, MINI-mvcq-2f8c-3r94, MINI-pjgm-cp6v-h9p4, MINI-r24g-ggm3-68gv, MINI-r255-v6j4-258j, MINI-r899-34pf-xp9q, MINI-rf5x-jg22-rv3g, MINI-vxh2-97w3-6g34, MINI-xh5w-hf9g-f876, MINI-xp3c-xr3h-mwcq, UBUNTU-CVE-2026-60589

## What is CVE-2026-60589?

CVE-2026-60589 is a low-severity vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Security).  Supported versions that are affected are Oracle Java SE: 8u501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2; Oracle GraalVM for JDK: 17.0.20 and  21.0.12; Oracle GraalVM Enterprise Edition: 21.3.19. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in  unauthorized read access to a subset of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 3.7 (Confidentiality impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-60589?

3 open source packages ship an affected version, including java, java-min and jre.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |

## How do I fix CVE-2026-60589?

Upgrade java to a fixed version for your release line: 1.8.0, 8.0.503, 11.0.32-1 or 17.0.20-1.

## Is CVE-2026-60589 being exploited?

There is no known exploitation of CVE-2026-60589 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-60589 and fix it if it is affected.

What it is: CVE-2026-60589 is a low-severity vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-60589 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-60589/ (Markdown: https://insights.sbomify.com/CVE-2026-60589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-60589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-60589
- OSV: https://osv.dev/vulnerability/CVE-2026-60589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-60589/
Summaries are generated and may contain mistakes; the official description above is the record.
