CVE-2026-6062 IDOR in Jira plugin subscription edit endpoint
An authenticated attacker can hijack subscriptions from unauthorized channels by bypassing ownership validation in the subscription edit endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6062?
CVE-2026-6062 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 Fail to validate channel ownership of an existing subscription before applying edits which allows an authenticated attacker to hijack subscriptions from channels they have no access to via a crafted PUT request to the subscription edit endpoint.. Mattermost Advisory ID: MMSA-2026-00650
Weakness: CWE-639
Which versions are affected by CVE-2026-6062?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.6 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.6 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.3 |
3 more packages
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.3 |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-6062?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.5.6+incompatible or 11.6.3+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-6062 being exploited?
There is no known exploitation of CVE-2026-6062 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-mxq2-5jpg-7474, GO-2026-6484.