# CVE-2026-6104: Global buffer over-read in mb_convert_encoding() with attacker-supplied encoding

> An attacker can trigger an out-of-bounds read in PHP's mbstring functions via crafted encoding names, potentially disclosing memory or causing a crash.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-libphp-2026-6104, BIT-php-2026-6104, BIT-php-min-2026-6104, DEBIAN-CVE-2026-6104, MINI-c599-q2v6-h6vp, MINI-fj8c-8w53-hcjg, UBUNTU-CVE-2026-6104

## What is CVE-2026-6104?

CVE-2026-6104 is a medium-severity vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.4.* before 8.4.21 and 8.5.* before 8.5.6, when an encoding name containing an embedded NUL byte is passed to mb_convert_encoding() or related mbstring functions, the code incorrectly assumes that when strncasecmp() returns 0 it means the strings have the same length. This can lead to out-of-bounds read of global memory, potentially causing a crash or information disclosure or crash. Affected functions include mb_convert_encoding(), mb_detect_encoding(), mb_convert_variables(), and mb_detect_order(), as well as the mbstring.detect_order and mbstring.http_output INI settings.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-6104?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |
| `php` | Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |
| `php-min` | Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |

Products: Php Php.

## How do I fix CVE-2026-6104?

Upgrade libphp to a fixed version for your release line: 8.4.21 or 8.5.6.

## Is CVE-2026-6104 being exploited?

There is no known exploitation of CVE-2026-6104 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6104 and fix it if it is affected.

What it is: CVE-2026-6104 is a medium-severity vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6104 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.4.0; fixed in 8.4.21, 8.5.6
- php (Bitnami): affected from 8.4.0; fixed in 8.4.21, 8.5.6
- php-min (Bitnami): affected from 8.4.0; fixed in 8.4.21, 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6104/ (Markdown: https://insights.sbomify.com/CVE-2026-6104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6104
- OSV: https://osv.dev/vulnerability/CVE-2026-6104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6104/
Summaries are generated and may contain mistakes; the official description above is the record.
