CVE-2026-6107 1Panel-dev MaxKB ChatHeadersMiddleware chat_headers_middleware.py cross site scripting

Medium 5.1 Published Updated

Remote attackers can execute arbitrary scripts via the ChatHeadersMiddleware Name argument, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-6107?

CVE-2026-6107 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 12 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2026-6107?

How do I fix CVE-2026-6107?

No fix has been published for CVE-2026-6107 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-6107 being exploited?

There is no known exploitation of CVE-2026-6107 in the wild and no public exploit code.

Sources

Also known as GHSA-96q3-fpgp-35xf.

Is CVE-2026-6107 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free