{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-6107 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-6107 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-6107 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 12 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6107 and fix it if it is affected.\n\nWhat it is: CVE-2026-6107 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 12 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-6107 in the wild and no public exploit code.\n\nAffected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6107/ (Markdown: https://insights.sbomify.com/CVE-2026-6107/index.md)","id":"CVE-2026-6107","markdown":"https://insights.sbomify.com/CVE-2026-6107/index.md","name":"CVE-2026-6107","record":{"aliases":["GHSA-96q3-fpgp-35xf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MaxKB web application","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the ChatHeadersMiddleware Name argument, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"1Panel-dev MaxKB ChatHeadersMiddleware chat_headers_middleware.py cross site scripting","id":"CVE-2026-6107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"1Panel-dev MaxKB Model Context Protocol Node base_mcp_node.py execute os command injection","id":"CVE-2026-6108"},"packages":[],"prev":{"headline":"1Panel-dev MaxKB Public Chat static_headers_middleware.py StaticHeadersMiddleware cross site scripting","id":"CVE-2026-6106"},"products":["MaxKB"],"published":"2026-04-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["1Panel-dev"]},"summary":"Remote attackers can execute arbitrary scripts via the ChatHeadersMiddleware Name argument, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2026-6107/"}