# CVE-2026-6107: 1Panel-dev MaxKB ChatHeadersMiddleware chat_headers_middleware.py cross site scripting

> Remote attackers can execute arbitrary scripts via the ChatHeadersMiddleware Name argument, potentially compromising user sessions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-96q3-fpgp-35xf

## What is CVE-2026-6107?

CVE-2026-6107 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 12 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6107?


## How do I fix CVE-2026-6107?

No fix has been published for CVE-2026-6107 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-6107 being exploited?

There is no known exploitation of CVE-2026-6107 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6107 and fix it if it is affected.

What it is: CVE-2026-6107 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 12 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6107 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6107/ (Markdown: https://insights.sbomify.com/CVE-2026-6107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6107
- OSV: https://osv.dev/vulnerability/CVE-2026-6107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6107/
Summaries are generated and may contain mistakes; the official description above is the record.
