# CVE-2026-6125: Dromara warm-flow Workflow Definition save-json SpelHelper.parseExpression code injection

> Remote attackers can execute arbitrary code via SpEL injection in the warm-flow workflow definition handler, requiring immediate library upgrades.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-822v-8w6h-5jxp

## What is CVE-2026-6125?

CVE-2026-6125 is a medium-severity code injection vulnerability in Dromara warm-flow, published on 12 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw has been discovered in Dromara warm-flow up to 1.8.4. Impacted is the function SpelHelper.parseExpression of the file /warm-flow/save-json of the component Workflow Definition Handler. The manipulation of the argument listenerPath/skipCondition/permissionFlag results in code injection. The attack may be performed from remote. The exploit has been released to the public and may be used for attacks.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-6125?

2 open source packages ship an affected version, including org.dromara.warm:warm-flow-plugin-modes-sb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dromara.warm:warm-flow-plugin-modes-sb` | Maven | All versions | 1.8.5 |
| `org.dromara.warm:warm-flow-plugin-modes-sb` | Maven | All versions | 1.8.5 |

## How do I fix CVE-2026-6125?

Upgrade org.dromara.warm:warm-flow-plugin-modes-sb to 1.8.5 or later.

## Is CVE-2026-6125 being exploited?

There is no known exploitation of CVE-2026-6125 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6125 and fix it if it is affected.

What it is: CVE-2026-6125 is a medium-severity code injection vulnerability in Dromara warm-flow, published on 12 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6125 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dromara.warm:warm-flow-plugin-modes-sb (Maven): affected all versions; fixed in 1.8.5
- org.dromara.warm:warm-flow-plugin-modes-sb (Maven): affected all versions; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6125/ (Markdown: https://insights.sbomify.com/CVE-2026-6125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6125
- OSV: https://osv.dev/vulnerability/CVE-2026-6125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6125/
Summaries are generated and may contain mistakes; the official description above is the record.
