# CVE-2026-6128: Cross-site scripting in All-in-One WP Migration Unlimited Extension

> Authenticated attackers can inject scripts into the plugin settings page, potentially compromising administrator accounts.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-vh38-jq6h-xh79

## What is CVE-2026-6128?

CVE-2026-6128 is a medium-severity cross-site scripting vulnerability in servmask All-in-One WP Migration Unlimited Extension, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The All-in-One WP Migration Unlimited Extension plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ai1wm_backups_path' parameter in all versions up to, and including, 2.84. This is due to insufficient input sanitization and output escaping on user-supplied attributes combined with missing authorization checks on the settings() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the plugin settings page. The vulnerability was partially patched in version 2.84.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6128?


## How do I fix CVE-2026-6128?

No fix has been published for CVE-2026-6128 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-6128 being exploited?

There is no known exploitation of CVE-2026-6128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6128 and fix it if it is affected.

What it is: CVE-2026-6128 is a medium-severity cross-site scripting vulnerability in servmask All-in-One WP Migration Unlimited Extension, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6128 in the wild and no public exploit code.

Affected product: servmask All-in-One WP Migration Unlimited Extension. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6128/ (Markdown: https://insights.sbomify.com/CVE-2026-6128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6128
- OSV: https://osv.dev/vulnerability/CVE-2026-6128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6128/
Summaries are generated and may contain mistakes; the official description above is the record.
